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Preface

An Introduction to
Impulse Response Utility

Impulse Response Utility is a multi-track audio recording and deconvolution application.
It is designed to enable you to create your own impulse response files for Space Designer,
the convolution-based reverb effect of Logic Studio. Although Space Designer comes
with plenty of great sounding Halls, Delays, and other Reverbs, you might want to create
an impulse response of your own studio, kitchen, bathroom, or even teapot.
This preface covers the following:
• About Impulse Response Utility (p. 5)
• About the Impulse Response Utility Documentation (p. 5)
• Additional Resources (p. 6)

About Impulse Response Utility
Impulse Response Utility is designed to work seamlessly with Space Designer. You can
record and edit impulse responses and create Space Designer files quickly and easily. All
tools needed to master the complex process of creating an impulse response, such as a
flexible sweep generator, powerful editing facilities, and one-click creation of Space
Designer settings, are included. All you need is your Mac, Impulse Response Utility and,
of course, an audio interface connected to speakers and microphones.

About the Impulse Response Utility Documentation
The Impulse Response Utility User Manual (this document) describes the
Impulse Response Utility application only. For information about Space Designer, see the
Logic Studio Effects manual.
• Impulse Response Utility User Manual: This document provides comprehensive
instructions for using Impulse Response Utility to create your own mono, stereo, and
surround impulse responses for Space Designer, the Logic Studio convolution-based
reverb effect.
• Logic Studio Effects: This document provides instructions for using the powerful collection
of effects included with Logic Studio.
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Additional Resources
Along with the documentation that comes with Logic Studio, there are a variety of other
resources you can use to find out more.
Release Notes and New Features Documents
Each application offers detailed documentation that covers new or changed features and
functions. This documentation can be accessed in the following locations:
• Click the Release Notes and New Features links in the application Help menu.
Logic Studio Website
For general information and updates, as well as the latest news on Logic Studio, go to:
• http://www.apple.com/logicstudio
Apple Service and Support Websites
For software updates and answers to the most frequently asked questions for all Apple
products, go to the general Apple Support webpage. You’ll also have access to product
specifications, reference documentation, and Apple and third-party product technical
articles.
• http://www.apple.com/support
For software updates, documentation, discussion forums, and answers to the most
frequently asked questions for Logic Studio, go to:
• http://www.apple.com/support/logicstudio
For discussion forums for all Apple products from around the world, where you can search
for an answer, post your question, or answer other users’ questions, go to:
• http://discussions.apple.com
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Preface

An Introduction to Impulse Response Utility

Understanding Deconvolution and
Impulse Responses

1

Space Designer combines, or convolves, an impulse response of an acoustic space with
an audio signal. The end result is that your audio is placed “inside” the acoustic space,
represented by that impulse response. Think of an impulse response as the total echoes
(reflections) in a given physical space, following an initial signal spike. The impulse response
file is simply an audio file recording made in a space that contains these echoes.
There are two practical approaches to impulse response recording: the Transients and
Sine Sweep methods.
This chapter covers the following:
• Impulse Response Recording: Transients Method (p. 7)
• Impulse Response Recording: Sine Sweep Method (p. 8)

Impulse Response Recording: Transients Method
This method involves the recording of an impulse in a space, using a device such as a
starter pistol. The gunshot is the impulse, and the audio file you record captures both
the impulse (gunshot) and the room response.
The advantage of this method is that the recorded audio file can be used in Space Designer
without any further processing. You can use Impulse Response Utility to record your
starter pistol impulses, and then combine them into a Space Designer Impulse Response
(.sdir) file (and Space Designer setting file).
The disadvantage of this method is that it’s extremely difficult to make a perfect,
undistorted recording of a starter pistol shot. This is due to the extremely loud nature of
the initial transient of the shot. A further issue is that starter pistol shots contain very little
high or bass frequency information—which, in turn, limits the usable frequency range
of the convolved reverb.

7

Impulse Response Recording: Sine Sweep Method
This is the preferred method for creating impulse responses. It involves playing a
broadband audio sine sweep into a space, and recording the sweep (and space) at optimal
recording levels. A sine sweep that covers the entire audible frequency range is used,
resulting in a broad-range, and often higher-quality, impulse response.
The recorded sine sweep audio file cannot directly be used as an impulse response. The
recorded file contains all the echoes and reflections—in other words, the response—of
the space, stretched out over the length of the sine sweep. This is very different from the
starter pistol approach, where the response is contained at the beginning of the file in an
impulse.
When you use a sine sweep, Impulse Response Utility uses a process called deconvolution
to time align and level align all recorded reflections-that are present over the entire
recorded sine sweep—into the very beginning of the file. This results in an impulse
response that Space Designer can use to combine, or convolve, with your audio signal.
Impulse Response Utility can then generate an .sdir setting from the impulse response.
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Setting Up Your Impulse Response
Recording Environment

2

Prior to using Impulse Response Utility to create an impulse response, you need to set
up your recording hardware—allowing playback and recording of the sine sweep that
Impulse Response Utility will generate.
The impulse response of a space is never just the space’s impulse response. The recorded
impulse response is always the response of the complete system—in other words, every
piece of equipment you use in the recording process. This includes, in signal-flow order:
the digital-to-analog converter, the amplifier and speakers (or powered speakers), the
room characteristics, the microphones, and finally the microphone pre-amp and
analog-to-digital converter. So, before leaving your studio to do any location recording,
you have to think about your equipment. These days, even budget converters offer
acceptable quality, so your main concern will be your selection of speakers and
microphones.
This chapter covers the following:
• Ideal Impulse Response Recording Setup (p. 9)
• Alternative Impulse Response Recording Setup (p. 11)
• Speaker and Microphone Selection Suggestions (p. 12)
• Speaker and Microphone Placement Suggestions (p. 12)

Ideal Impulse Response Recording Setup
When making an Impulse Response recording, ideally you will have:
• One speaker for each (speaker) location required by the chosen format, if you are going
to be generating sine wave sweeps. As examples: If you are recording a true stereo
impulse response, you will need two speakers; if you are recording a six channel
surround impulse response, you will need six speakers, and so on. If you are not
generating sine wave sweeps, you don’t need speakers to play them back (the sound
is generated by the starter pistol).

9

Note: In many cases, it is sufficient to record one speaker position (but all microphone
positions required by the chosen impulse response format), and create a mono/omni
discrete impulse response. This will result in a less CPU-intensive impulse response in
the required format. See Recording a Mono to Omni 5 Channel Impulse Response.
• One or more microphones to record the resulting audio from each speaker (or your
starter pistol) combined with its echo reflections. The number of microphones you will
need depends on the chosen impulse response format. As examples; if you are recording
a six channel surround impulse response, there are six microphone positions, so ideally
you would have six microphones; if you are recording a six channel B-Format encoded
impulse response—where only one microphone position and four tracks are
required—you would need fewer microphones, and so on. See B-Format Surround
Encoding for more information.
• An audio interface that offers enough outputs to send a broadband audio sine sweep
into each speaker (if using sine sweeps), and enough inputs to record the resulting
audio from each position.
Note: You may also need additional microphone pre-amplifiers if you find that your
microphones can’t capture a strong enough signal, or your audio interface doesn’t offer
enough mic pre-amp inputs.
Example of speakers and microphones set up to capture a 5.1 multi-channel impulse response
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Computer

Alternative Impulse Response Recording Setup
It is possible to make discrete multi-track impulse responses—even if you don’t have
enough speakers or microphones. As you will only be recording one sine sweep at a time,
you can set up as many speakers as you have, record them into Impulse Response Utility,
then move the speakers to new positions, and repeat the process. To give you an example,
imagine you only have a stereo pair of speakers, but want to create a quadraphonic
impulse response, which requires the recording of four tracks in four different speaker
positions. You could set up your pair of monitors, record their output, then move them
to record the other pair of tracks in the other two speaker positions.
This method of creating impulse responses is obviously more time-consuming, and not
having all your speakers set up at once makes optimal monitor placement—relative to
each other—difficult. With time and careful planning, however, you can still achieve the
same results.
You can also create multi-channel impulse responses in Impulse Response Utility through
use of the Mono to Omni Discrete impulse response format. This only requires the
recording of one speaker by as many “channel” microphones as needed (for the chosen
format). The resulting impulse response places a lower strain on your CPU. See Recording
a Mono to Omni 5 Channel Impulse Response.
If you have enough monitors, but not enough microphones, you can set up the required
speakers, and move your available microphones between them. This makes optimal
microphone placement—relative to other microphones—difficult, but you still have the
advantage of optimal speaker placement (and it’s considerably easier to move microphones
than speakers).
If your audio interface doesn’t have enough inputs and outputs—for the number of
speakers and microphones you are using to create your impulse response—you can still
set up all mics and speakers. As you record different tracks into Impulse Response Utility,
you will need to disconnect/reconnect the speakers and microphones, in turn.
A more detailed discussion of speakers and microphones that are suitable for creating
impulse responses, as well as suggestions on speaker and microphone placement, is
found in Speaker and Microphone Selection Suggestions and Speaker and Microphone
Placement Suggestions.
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Speaker and Microphone Selection Suggestions
There are no rules as to which brand or make of microphone or speaker will result in the
best impulse response. A general guideline is to use speakers and microphones with a
flat response (in other words, the speakers and microphones should offer a very even
signal at all frequencies). You can find microphones and speakers that offer relatively flat
responses at nearly all budget levels. Tube microphones, which are generally valued for
the tonal “color” that they add to the signal, are not necessarily the best choice for
recording impulse responses. In general, microphones that work well as ambience mics
are good candidates.

Speaker and Microphone Placement Suggestions
Where you place your speakers and microphones in the recording space will have a large
impact on the specific echoes and reflections that your impulse response captures. It
goes without saying that creativity is key, and experimentation the name of the game.
There are, however, some general suggestions and guidelines that may help when you
make your initial recordings.
One general suggestion for placement in environments with hard floors, made from
materials such as concrete: You may find that a “chirp” is recorded at the beginning of
your impulse response. This sound is actually the generated sine sweep resonating through
the floor into the microphone stand, and then into microphone itself. The speed of sound
through floors and concrete material is much faster than through air, resulting in a
pre-impulse response that starts before the impulse response you actually want to record.
To circumvent this potential problem, you can use “studio” drum pedestals and specialized
microphone mounts that have strong acoustic absorbers built into them. If you can’t
transport pedestals, or afford expensive microphone mounts, try a thick carpet under the
speakers and microphone stand(s).
Below are some specific approaches for you to experiment with when creating impulse
responses. Remember, these are just suggestions. There are no rules regarding how far
the speakers need to be placed away from the microphone array, the best angles, ideal
distances between speakers and microphones, and so on. You may want to try a number
of different techniques and placements to find the ideal arrangement. Creating impulse
responses is an art unto itself.

The Virtual Listener Approach
This is perhaps the most common technique for placing speakers and microphones when
creating impulse responses. The goal is to capture the effect of the echoes and reflections
coming from all around the space—as heard at the listening position. In this approach,
the speakers are set up at the edges of the room, and the microphone is placed in the
listening position.

12
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The resulting impulse response (when later used in Space Designer to add reverb to your
signal) should sound like your audio is being played back from the various speaker
locations in the “space.” This method doesn’t require multiple microphones; a single
microphone can be turned toward each speaker in turn, and different audio recordings
can be made from the same location. The image below illustrates the virtual listener
approach to setting up five speakers (for a five channel surround impulse response), with
one microphone placed centrally in the space.
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This method can create the impression of the audio signal being completely immersed
in the simulated space.
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The Auralization Approach
Another common strategy for placing speakers and microphones in a space uses the
auralization approach. This technique attempts to capture the reflections from the
performer’s perspective. Place one or more speakers at the performer’s location (or another
audio source) and place the microphone at the listening position. The resulting impulse
response should sound like your audio is being played back from these specific speaker
locations. For example, you can make a stereo impulse response of a particular stage
using the auralization technique, and when you use the IR in Space Designer, your audio
should sound like it is on that stage. The image below illustrates use of the auralization
technique to set up your speakers and microphones for a true stereo impulse response.
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To capture a surround impulse response that represents being “in the audience” of a
space, set up two speakers in the performer’s position as above, but place a surround
array of microphones around the room. This can create a realistic feeling (and effect) of
being “in the audience” when the performance is coming from in front of you. This can
help to create a surround-like effect from a live stereo recording.
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The Virtual Echo Chamber Approach
A good alternative to the auralization approach is placement of your speakers and
microphones in a way that creates a virtual space that resembles a physical echo chamber.
To create this kind of impulse response, face the loudspeakers toward the corners, and
the microphones toward the opposite corners. This is how microphones in a physical
echo chamber would be placed. This eliminates a direct path from the speaker to the
microphone, and captures more reflections. The image below illustrates how you could
set up two speakers and two microphones to create a stereo impulse response, using
this virtual echo chamber approach.

R

L

The resulting impulse response allows you to mix the reverb into the dry signal, without
any phase cancellation issues caused by early reflections or direct signals. This approach
works particularly well if you want to keep your signal mostly dry, without any alteration
or coloration from the reverb, but still want to add a high fidelity reverb tail to your audio.
You can also use this method for surround or multi-channel reverbs. The main concept
to remember is that the speakers should be pointing at the wall, to eliminate direct paths
between microphones and speakers. The illustration below offers a possible layout for a
five channel reverb chamber. The loudspeakers, placed in a circle, are directed at the
walls, and the microphone array is in the center of the circle.
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Creating Impulse Responses in
Impulse Response Utility

3

This chapter covers the creation of your own impulse responses for use in Space Designer.
This chapter covers the following:
• Getting to Know the Interface (p. 18)
• Understanding the Workflow (p. 18)
• Creating Your Project (p. 19)
• Assigning Input and Output Hardware (p. 20)
• Configuring the Monitoring Parameters (p. 21)
• Configuring the Sweep Generator (p. 22)
• Recording Audio into Impulse Response Utility (p. 23)
• Deconvolving Your Impulse Response (p. 26)
• Editing Your Impulse Response (p. 27)
• Auditioning Your Impulse Response (p. 28)
• Creating a Space Designer Setting (p. 30)
• Saving, Opening, and Reverting to Saved Projects (p. 31)

17

Getting to Know the Interface
All parameters and functions that you need to create impulse responses are contained
in a single screen.
Hardware I/O
Assignment area

Monitor and Sweep
Generator section

Editing area

Inputs/Track section

The Impulse Response Utility interface is divided into four areas:
• Hardware I/O Assignment area: Contains pop-up menus that enable selection of the
audio input and output device.
• Monitor and Sweep Generator section: Contains monitoring and sine sweep generation
parameters, plus buttons to deconvolve your audio tracks into an impulse response,
and to audition your IR.
• Inputs/Track section: Lists all audio tracks used for your impulse response recordings.
• Editing area: Displays the audio information of the currently selected audio track.

Understanding the Workflow
Creating an impulse response in Impulse Response Utility consists of the following stages:
Stage 1: Creating a New Impulse Response Project
Configure your Impulse Response Utility project for the number of tracks your impulse
response format requires.
Stage 2: Setting Impulse Response Utility Parameters
Set the hardware I/O, monitor, and sweep parameters for your audio track recordings.

18
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Stage 3: Recording
Use Impulse Response Utility to record the audio tracks needed for your impulse response.
Stage 4: Deconvolving Your Audio Recordings
Assuming you have recorded sine sweeps, click Deconvolve after all audio tracks have
been recorded. Impulse Response Utility will generate an impulse response from your
tracks.
Stage 5: Editing and Auditioning
Cut silent portions, apply fades, and so on, to optimize your impulse response.
Stage 6: Creating a Space Designer Setting
Click Create Space Designer Setting when finished with the steps above. This adds the
newly created impulse response to your list of available Space Designer settings.

Creating Your Project
When you first open Impulse Response Utility, you will be presented with the New Impulse
Response Project dialog. This is the first step in creating a new impulse response project.
You can also create a new impulse response project by choosing File > New Project (or
pressing Command-N).

Impulse Response Utility offers formats ranging from conventional stereo impulse
responses, true stereo (where each channel is processed discretely), quadraphonic formats,
or five, six, or seven channel surround formats. These latter formats can be in either
traditional multi-track, or B-Format encoding. See B-Format Surround Encoding for more
information.
You can also create multi-channel impulse responses in Impulse Response Utility by using
the Mono to Omni Discrete impulse response format. This only requires the recording of
one speaker by as many “channel” microphones as needed (for the chosen format). The
resulting impulse response places a lower strain on your CPU. See Recording a Mono to
Omni 5 Channel Impulse Response.
To create a new impulse response project
1 Choose an impulse response format from the Configuration pop-up menu.
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In the window below the Configuration pop-up menu, the dialog displays the number
of speaker and microphone positions required by the selected format.
2 Click OK
This exits the New Impulse Response Project dialog, and the required number of tracks
(determined by the format you chose) are shown in the Inputs/Track section.

Assigning Input and Output Hardware
You need to set up the audio input and output device in the Hardware I/O Assignment
area before you can use Impulse Response Utility.

The audio input selection determines the audio device used to record audio tracks. The
audio output selection determines the audio device used to monitor the recorded signal,
and to play back the generated sine sweep.

µ

To select an audio input device
In the Audio Input pop-up menu, choose an audio interface driver.

µ

To select an audio output device
In the Audio Output pop-up menu, choose an audio interface driver.
Note: Although the Hardware I/O Assignments area also displays the current sample rate,
you cannot change the sample rate of your impulse response project in
Impulse Response Utility. If you want to record your audio tracks at a different sample
rate, you will need to change it in the Audio MIDI Setup utility, or in the software for your
audio interface (if applicable). Consult the documentation for your audio interface if you’re
unsure.
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Configuring the Monitoring Parameters
Once you have recorded sine sweep tracks into Impulse Response Utility, you can monitor
them through a stereo output of your choice. The monitor controls determine the monitor
channel and level. You can also mute the monitor section.

µ

To select the stereo monitor output channels
Choose the desired stereo output pair from the Monitor Channel menu.

To adjust the output level of the monitored signal
1 Click inside the Monitor Level field.
2 Do one of the following:
• Drag left (or down) to reduce the volume, or right (or up) to raise the volume.
• Type a numeric value for the monitor level (any value above 0 dB will set the monitor
level at 0 dB).
Important: To avoid audio feedback when recording, be sure to mute the monitor output.

µ

To mute the monitor output
Select the Monitor Mute checkbox.

Chapter 3 Creating Impulse Responses in Impulse Response Utility
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Configuring the Sweep Generator
The sweep generator produces a sine wave that sweeps smoothly from 20 Hz up to
20 kHz. The sweep generator parameters set the hardware output, volume, length, reverb
time, and pre-roll of the sine sweep.

• Sweep Channel pop-up menu: Choose the input channel that you want to use.
• Test Tone pop-up menu: Choose a test tone frequency for the integrated, sustaining (in
other words, non-sweeping) sine wave tone generator. This facility helps you to calibrate
your hardware outputs. Use this test tone to ensure that your hardware output channel
is connected properly, and that your speakers can reproduce the selected sine wave
frequency.
• On checkbox: Select to hear the test tone.
• Sweep Level field: Sets the level of the test tone.
• Sweep Length pop-up menu: Sets the sweep duration. Ideally, you want your sine wave
to be short. This avoids artifacts in your recording due to air motion, rattling of interiors,
and other ambient noise. Unfortunately, short sweeps may not yield high enough
signal-to-noise ratios in some recording situations. If you find that the results obtained
from recording with a 10-second sweep aren’t all you hoped for, try the 50-second
sweep.
There are three length options for the sine sweep:
• 10s: A 10-second sine sweep
• 50s: A 50-second sine sweep
• Off: No sine wave sweep. Choose this setting if you are recording a starter pistol
impulse.
• Reverb Time field: Determines the maximum recording time for each track. In order to
accurately capture the acoustic properties of a space, you should set a value that is
long enough to capture the decay phase of all reverberations and echoes.
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If you are using the sweep generator, the reverb time will start when the sine sweep
ends. If you have the Sweep Length set to Off (in order to record a starter pistol impulse
response), the Reverb Time parameter determines the entire length of the recording.
• Preroll checkbox: You want to be sure that any operator noise, such as typing, readjusting
microphones, and so on, is not recorded. You can set a pre-roll for just this purpose;
recording won’t start immediately, giving you time to finish typing, make last-minute
mic corrections, and so on. The pre-roll length equals the time you set with the Reverb
Length parameter.

Recording Audio into Impulse Response Utility
Once you have made hardware assignments and configured the monitor and sine sweep
parameters, it’s time to start recording audio tracks.
If you are using the sweep generator, you will hear the sine wave sweep up through its
frequency range. Impulse Response Utility will record the result onto the selected audio
track(s).
If you have set the sweep generator to Off, click Record, and shoot your starter pistol.
Impulse Response Utility will record the resulting impulse response onto the selected
track.
To select an audio track
Do one of the following:

µ
µ

Click in a track lane.
Use the Up and Down Arrow keys to navigate through the track list.

To record in Impulse Response Utility
1 Select an audio track in the Inputs/Track section.
2 Configure the audio track for recording.
3 Repeat this step for each track required by the chosen format.
4 Click the Sweep/Record button to begin recording.
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Configuring Audio Tracks for Recording
The Inputs/Track section is automatically filled with the number of tracks required for the
impulse response recording, based on your selections in the New Impulse Response
Project dialog. Every track lane in the Inputs/Track section has a number of parameters.
Some are automatically configured by Impulse Response Utility; others you will need to
set before recording.

Track Parameters
• Speaker Position pop-up menu: Selects the speaker position label for the selected track.
Both Impulse Response Utility and Space Designer use these labels to identify, and
process, the audio files that comprise a multi-channel stereo or surround impulse
response. Impulse Response Utility automatically sets the speaker position label for
each track, but you can change these labels to any other position (available in the
current impulse response format), if desired.
• Mic Position pop-up menu: Selects the mic position label for the selected track. Both
Impulse Response Utility and Space Designer use these labels to identify, and process,
the audio files that comprise a multi-channel stereo or surround impulse response.
Impulse Response Utility automatically sets the mic position label for each track, but
you can change these labels to any other position (available in the current impulse
response format), if desired.
• Input pop-up menu: Sets the physical input for each track. Be sure to select the correct
input before recording.
• S[olo] button: Click to engage or disengage solo mode for the selected track. When the
Solo button is engaged (yellow), the input signal is routed to the monitor section, and
the input level is displayed in the VU meter (see “VU meter” below). Only one track can
be soloed at a time.
• R[ecord-Enable] button: Places the selected track into record-ready mode. The R button
turns red when engaged. Clicking this button also activates the Solo button for the
selected track, allowing you to monitor the input signal before recording. You can
record-enable several tracks at once, for multi-channel recording. When you click
Sweep/Record, a recording will be made on all record-enabled tracks.
• L[ock] button: As soon as one track is locked, the sweep generator parameters are also
locked. This ensures that any subsequent recordings will use identical sweep settings.
This is necessary, as every track must use an identical sine sweep—in order to produce
a phase coherent, accurate, multi-channel impulse response.

24
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• Peak field: Displays the peak level value in dB. If the level ever exceeds 0 dB, the peak
value is held until cleared. Clicking the Peak column header resets the Peak readout
for all tracks.
• Level: Displays input meters for each track. These level meters always show the current
level of the physical inputs.
VU Meter
Measures either the signal level present at the (soloed) track input, or the sweep generator
output. During playback of recorded audio, the VU meter displays the level of the selected
track. A status message below the VU meter shows its current operating mode. The
VU meter scale ranges from 0% to 100%, with 100% equalling 0 dB.

Making a Recording
Once you have configured and record-enabled the desired tracks, click the Sweep/Record
button. If you are using the sweep generator, the button shows “Sweep.” If you are not
using the sweep generator (Sweep Length parameter is set to Off ) the button shows
“Record.”
• Clicking Sweep automatically starts the recording process and generates the sine sweep.
The VU meter is automatically switched to display the sweep generator output.
• Clicking Record automatically begins the recording process. Shoot your starter pistol
and Impulse Response Utility will record the audio.
Recording will continue until the entire sine sweep (if the sweep generator is being used)
and Reverb Length time has elapsed. The recording automatically ends. You can abort
the recording process by clicking the Sweep/Record button.
Note: The Sweep/Record button is disabled if no track is record-enabled.
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Automatic Saving of Projects
Impulse Response Utility records into your computer’s RAM, not to your hard disk. This
means that nothing you have recorded is saved, until you save your project.
For your convenience, Impulse Response Utility automatically saves your project to disk
after every recording.
If you haven’t saved your project, the Save dialog is opened, allowing you to name your
project, and choose a hard disk location. If you have already saved your project, the
save process happens automatically. See Saving, Opening, and Reverting to Saved
Projects for more information.

Deconvolving Your Impulse Response
Deconvolution is the process used to create impulse responses from (recorded) broadband
audio sine sweeps. If you use the sweep generator, you will need to deconvolve your
audio recordings—in order to make them usable as an impulse response.
To deconvolve your audio tracks
Do one of the following:

µ

Click the Deconvolve button.

µ

Choose Edit > Deconvolve (or press Shift-Command-D).
Following deconvolution, your audio tracks will be a single impulse response that you
can audition, edit, and turn into an .sdir setting.
Note: While it is possible to deconvolve each audio track once recorded, there’s really no
point in working this way; it’s far more efficient to wait until all tracks are recorded, and
then deconvolve them.
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Editing Your Impulse Response
When you have finished recording your audio tracks, you may feel that they have
superfluous silence at the beginning or end of the file, don’t fade out early enough, and
so on. To address these minor issues, Impulse Response Utility allows you to cut, crop,
and fade your audio files in the Editing area.

µ

To view an audio file in the Editing area
Select the audio file.
Your audio file will automatically appear in the Editing area.

You can choose from three different display modes by clicking the buttons at the top of
the Editing area:
• Waveform button: Shows the recorded audio as a standard waveform. The horizontal
axis displays the elapsed time. The vertical axis displays the audio level as a percentage.
• Energy button: Shows the sound energy distribution over time. The horizontal axis
displays the elapsed time. The vertical axis displays audio levels in dB.
• Spectrogram button: Shows the frequency distribution over time. The horizontal axis
displays the elapsed time. The vertical axis displays the frequencies, which are
color-coded by dB range. The color legend in the upper-right corner of the Editing area
indicates the color schema.
These display modes allow you to effectively analyze your waveforms, making it easy to
identify material you need to cut or crop, or that requires a fade. The Spectrogram mode,
in particular—which simultaneously shows frequency, level, and time—allows for very
detailed analysis of your audio.
To select and play part of an audio file in the Editing area
1 Drag horizontally over the desired section.
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2 Audition your selection by clicking the Play button. Click the Cycle button to continuously
play back the selected track.

µ

To edit the selected part of an audio file
Choose one of the editing operations from the buttons at the top-left corner of the Editing
area:
• Crop button: If you make a selection that doesn’t extend to either the beginning or end
of the audio, the left edit button activates the Crop function. Clicking this button will
remove the audio to the right and left of your selection, without touching the selected
audio. You can also choose Edit > Crop (or press Command-X) to crop.
• Cut button: If you make a selection that extends to either the very beginning or very
end of the audio, the left edit button activates the Cut function. Clicking this button
will remove the selected audio, without touching the unselected audio. You can also
choose Edit > Cut (or press Command-X) to cut.
• Fade button: If you make a selection that includes either the very beginning or end of
the audio, you can select the Fade function. Clicking this button creates a gradual fade
over the length of the selection area. You can also choose Edit > Fade (or press
Command-F) to fade.
Note: In order to maintain phase coherency between all tracks of your impulse response,
edits are performed across all tracks equally. To ensure that your impulse response cannot
include tracks that are not edited equally, you are prevented from recording further tracks
once an edit has been made.

Auditioning Your Impulse Response
To really know how your impulse response will sound when used in Space Designer, you
need to be able to listen to it in context. Impulse Response Utility includes an Audition
window for just this purpose, where the loaded impulse response can convolve test audio
files. The Audition window is divided into three sections: the Impulse Response area, the
Monitor area, and the Audio Test Files area.
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The appearance of the Audition window changes slightly when using a B-Format impulse
response. The B-Format Audition window removes the Output Channel parameter from
the Track area and includes a Loudspeaker area:

Audition Impulse
Responses window

Audition B-Format
Impulse Responses
window

Impulse Response Utility allows up to five audio files to be loaded/used as sources when
auditioning your impulse response. The Audition window also includes four test source
files.

µ

To open the Audition window
Click the Audition IR button.
The Audition window will open. All editing functions are disabled while the Audition
window is open.
Audition Impulse Response Window Parameters
• Enable checkbox: Enables or disables individual impulse response recordings. Use these
boxes to select the specific file (or files) you want to audition.
• Input ID label: Identifies the specific impulse response file by its speaker > mic positions.
• Output Channel pop-up menu (not available for B-Format Impulse Responses): Selects the
physical output channel used for playback of the selected impulse response.
• Mix field: Determines the ratio of dry test source signal to wet effect signal.
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• Monitor Level field: Sets the overall auditioning volume.
• Test Audio File buttons: Plays one of the four included test source audio files.
• Open buttons: Click to load an audio file for use as a test source. Any uncompressed
audio file can be used.
• Play buttons: Click to play the selected audio file through the enabled impulse response
file (or files).
Loudspeaker Area Parameters (B-Format Specific)
• Number of Loudspeakers field: Determines the number of loudspeakers that
Impulse Response Utility will decode the impulse response into. Click the arrows to
increase or decrease the number of speakers, or double-click the number of speakers
and type in a new value.
• Loudspeaker Angle field: Allows you to configure the angle of each loudspeaker. The
B-Format decoding takes this into account when re-creating the recorded space.
• Output Channel pop-up menu: Sets the physical output channel for the selected
loudspeaker.

Creating a Space Designer Setting
Once you are satisfied with your impulse response, the final step is to generate an .sdir
file, and a plug-in setting. When done, your newly created impulse response can be used
in Space Designer.
To create a Space Designer setting
Do one of the following:

µ

Click the Create Space Designer Setting button.

µ

Choose File > Create Space Designer Setting.
Impulse Response Utility will generate an .sdir file of your impulse response and save it
in the following directory: ~/Library/Application Support/Logic/Impulse Responses.
A plug-in setting file for your impulse response is also generated and saved in the following
directory: ~/Library/Application Support/Logic/Plug-In Settings/Space Designer.
The next time you open Logic, your newly created impulse response will be available in
the Library, and within the Space Designer interface.
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Saving, Opening, and Reverting to Saved Projects
The Impulse Response Utility project file is a Mac OS X package file, that contains all files
associated with the project.

Saving Projects
Impulse Response Utility automatically saves your project as soon as you record audio
(see Automatic Saving of Projects). You can manually save your project at any time,
however. You can also open a previously saved project, or revert the current project back
to its last saved state.

µ
µ

To save your project with its current name and location
Choose File > Save Project (or use Command-S) to save your IR Project with its current
name, in its current location.
To save your project with a new name or location
Choose File > Save As (or use Command-Shift-S).

Opening Projects
If you’d like to continue working on a previously saved project, you first need to open it.

µ
µ

To open a project
Choose File > Open Project (or press Command-O), then navigate to your project file.
Choose File > Open Recent to open a hierarchical menu of recently opened project files.

Reverting to Saved Projects
If you are unhappy with the edits or recordings made in your current project—and you
have saved the project—you can use the File > Revert to Saved command. This returns
the project to its last saved state.
Note: Once you use the Revert to Saved command, you will lose all unsaved changes.
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Recording Impulse Responses from
Audio Equipment

4

You aren’t limited to creating impulse responses from rooms and spaces. You can make
an impulse response from any device that you can play a broadband sine sweep into
(and record the results). Two examples are guitar speaker cabinets and hardware
processing devices, such as tube equalizers and reverb effects units.
This chapter covers the following:
• Recording Impulse Responses from Guitar Speakers (p. 33)
• Recording Impulse Responses from Hardware Devices (p. 34)

Recording Impulse Responses from Guitar Speakers
The sound of an electric guitar through a guitar amplifier is very heavily influenced by
the frequency response and tonal color of the guitar speaker cabinet. If you make an
impulse response from a guitar speaker cabinet, and then run a direct guitar amp signal
through that impulse response in Space Designer (set to 100% wet), the direct signal will
sound as if it was played through the speaker cabinet.
You will still need a microphone and audio interface to create an impulse response from
a guitar speaker cabinet, but you won’t need an additional monitor speaker for the sine
sweep—you will play the broadband sine wave into the guitar amp/speaker itself. If your
guitar amplifier has an effects return, you can use it to create the impulse response. If
your guitar amp does not have an effects return, you can either use a “re-amp” box (that
will raise the impedance of your audio interface’s line out to the level required by your
guitar amplifier at its input), or you can use a line level amplifier in place of your guitar
amplifier (to amplify the sine sweep through the guitar cabinet).
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You can experiment with microphone placement just as you would when miking a physical
space, although the most common microphone placement is “close miking”—placing
your microphone as near as one inch from the speaker itself. The illustration below shows
how you might want to set up your guitar speaker cabinet when creating your impulse
response.

Guitar amplifier
with microphone

Audio interface

Computer

Recording Impulse Responses from Hardware Devices
Imagine that you want to create an impulse response from your favorite tube microphone
pre-amp, allowing you to use its unique color on your audio. This way, you can run a
signal through this impulse response in Space Designer (set to 100% wet) and add the
color of your microphone pre-amp to the signal.
This scenario requires neither speakers nor microphones. You can simply connect the
output from your audio interface to the input of your hardware device, and play the sine
sweep through it. Connect the output of your hardware device to the input of your audio
interface, and record it back into Impulse Response Utility. You can use this method to
make impulse responses from classic hardware reverbs, multi-effects units, equalizers,
and so on.
You should take care when making impulse responses from hardware effects devices
that include modulation effects. Modulations such as phasing, choruses, and so on,
interfere with the sine sweep itself, which makes deconvolution difficult or impossible.
This is also true for some reverbs, such as classic Lexicon hardware reverb devices, in
which the reverb tails are modulated. In these cases, you may be better off sending a
recorded impulse (such as a recorded spike or gunshot) through the hardware effects
device, instead of a sine sweep.
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B-Format Surround Encoding

5

B-Format is a special way of encoding spatial information. It represents space using four
audio streams: one to capture the sound pressure (W), and three to capture the X
(front-to-back), Y (left-to-right), and Z (top-to-bottom) room coordinates. The following
illustration shows you how these four audio streams interact with each other, to create
a three-dimensional spatial image.
Height
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Space Designer can decode and convolve these four streams into reverbs, in all supported
surround formats. Space Designer offers a comprehensive library of B-Format impulse
responses that use all four streams (W, X, Y, and Z). As impulse responses do not make
use of Z-axis information, Impulse Response Utility only records and encodes information
from the W, X, and Y positions, saving CPU resources and disk space.
Impulse Response Utility allows you to encode all supported surround impulse response
formats in B-Format.
This chapter covers the following:
• Advantages of B-Format Surround Encoding (p. 36)
• Microphone Suggestions for B-Format Recording (p. 36)

35

Advantages of B-Format Surround Encoding
One advantage of the B-Format is that it can capture a surround image with fewer audio
files. Normally, you need to record every speaker position from every microphone position,
to correctly record surround information. With B-Format, these four (or three, in
Impulse Response Utility) audio streams are all you need to capture audio from each
speaker.
As an example, imagine you are using a five channel setup, and want to use
Impulse Response Utility to create a five channel impulse response. Using traditional
methods, you would need to record all five speakers from all five microphone positions,
resulting in 25 audio files. If you choose to create your project as a five channel B-Format
impulse response, you will only need to record 15 audio files—three audio recordings
(W, X, and Y) from each of the five speaker positions. As you can see, B-Format encoded
surround impulse responses require far fewer audio files, which means they require less
hard drive space, as well as needing less RAM and CPU cycles when decoded in Space
Designer.
A second advantage to B-Format encoding is phase coherency when using multiple
microphones at once. Whenever you use multiple microphones, differences in the time
it takes sound to reach each microphone can result in phase cancellations and phase
shifts, which can affect the quality of your impulse response. As the point of reference is
always the same when using B-Format encoding, there will be no phase issues, even
when using multiple microphones to record your impulse response.

Microphone Suggestions for B-Format Recording
Perhaps the ultimate B-Format recording microphones are the SoundField single point
source microphone series. These microphones contain all the capsules you will need to
make a complete B-Format reference recording in one pass, and include hardware to
send the separate axis streams to individual Impulse Response Utility tracks. You will only
need to swivel the mic once toward each speaker position, and the mic and processing
hardware does the rest. For those who can’t afford SoundField mics,
Impulse Response Utility provides additional microphone options for B-Format recording.
Capturing the W (sound pressure) signal requires an omni-directional microphone.
Capturing the X and Y axis signals requires a microphone with a figure-eight pattern (to
capture signal from the front and back of the mic). Therefore, with two figure-eight
patterned microphones—one pointed directly at the speaker source (X), and another
positioned perpendicularly (Y)—and an omni-directional microphone for the sound
pressure (W), you can record each speaker position in one pass. Be sure to arrange the
microphones so that their capsules are as close as possible to each other—ideally, you
want to have a single, tight point of reference for each speaker position.
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You will need to swivel each of the figure-eight pattern microphones to each speaker
position. The omni-directional microphone will not need to be swiveled, as it has a
360-degree capsule.
Even if your budget is too limited for three separate microphones, you can still create
B-Format impulse responses by recording each audio stream separately into
Impulse Response Utility. All you need is a microphone that allows you to switch between
omni-directional and figure-eight patterns. Many good microphones (at all budget levels)
have this capability. You will need to do a significant amount of pattern-switching and
microphone swiveling, but it can be done.
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Appendix

Impulse Response Utility Tutorial

This appendix walks you through the complete process of creating an impulse response,
from project start through to final Space Designer setting. For this tutorial, imagine that
you have permission to record in a particularly good-sounding local concert hall. You
have decided to record a discrete five channel surround impulse response, as you’ll
probably never have this opportunity again.
This appendix covers the following:
• Creating a Five Channel Surround Impulse Response (p. 39)
• Recording a Mono to Omni 5 Channel Impulse Response (p. 40)

Creating a Five Channel Surround Impulse Response
The stages outlined below should be followed when you want to create a discrete five
channel surround impulse response.
Stage 1: Microphone and Speaker Setup
The first thing you’ll want to do is set up your speakers and microphones. Imagine you’ve
decided to use the virtual listener approach—which requires five speakers and at least
one microphone in the middle—which can be turned toward each speaker in turn. Ideally,
you will have five identical, powered monitors. This will save you time when recording
audio, and will allow you to see all speakers at once, to ensure they are each the same
distance from the corners and walls, and so on. When all speakers have been positioned,
you need to set up your microphone in the middle of the hall. Make sure everything is
properly connected to your audio interface.
Stage 2: Creating a New Project
The next step is to open Impulse Response Utility and create a new five channel impulse
response project. The New Impulse Response Project dialog informs you that this format
requires five speaker positions and five mic positions. When you exit the dialog, 25 audio
tracks will appear in the Inputs/Track section—one for each speaker position, from every
microphone position.
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Stage 3: Configuring Impulse Response Utility Parameters
Position your microphone toward the speaker you want to record (the left front speaker,
for example). Set up the Monitor section, sweep generator, and input for the selected
track.
Stage 4: Recording
Record-enable the selected track, and click the Sweep button. Impulse Response Utility
will prompt you to name and save the new project after your first recording.
Swivel the microphone to the second surround position, record-enable the track, and
click the Sweep button. Once the recording has completed, the project will automatically
be saved in the background. You may want to play back the track in the Editing area, just
to double-check the recording.
Repeat this process another 23 times, until you have recorded all 25 audio tracks needed
to capture all possible microphone and speaker position combinations.
Stage 5: Deconvolving
Click the Deconvolve button after you have recorded (and checked) the audio files at
each position. At this point, you should save the project.
Stage 6: Editing and Auditioning
If you have any unwanted silence at the beginning or end of your impulse response, use
the Editing area to remove it. Use the Audition window to play some test material through
your impulse response, to make sure that you’re satisfied with the result. If not, edit your
impulse response further. If you still aren’t satisfied, go back to step 2 or 3, and start over.
Stage 7: Creating a Space Designer Setting
Once you are fully satisfied with your impulse response, you’re ready to click Create Space
Designer Setting. Impulse Response Utility generates the .sdir and Space Designer settings
files. Your new impulse response will be available the next time you open Space Designer.

Recording a Mono to Omni 5 Channel Impulse Response
The process in Creating a Five Channel Surround Impulse Response is an example of
recording a true surround impulse response. In many cases, it is sufficient to record one
speaker position, thus creating a mono/omni discrete impulse response. Mono/omni
discrete impulse responses are not only easier and faster to record, but also place a lower
strain on the CPU.
To create a mono to Omni 5 Channel impulse response
1 Choose the Mono/Omni to 5 channel template in the New Projects dialog.
You will see that mono/omni discrete projects only require one speaker.
2 Aim your speaker toward the ceiling or a back wall.
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3 Point your microphone to the first surround position: Front-Left, for example.
4 Record the sweep.
5 Repeat the process for all remaining microphone positions.
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