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Welcome to Logic Express 1

If you are new to Logic Express or have a limited knowledge of
the application, this guide is for you.

Each chapter of this book presents major features and guides you in trying things out.
Chapter 2 lets you build a basic project from scratch, while the remaining chapters take
you through the entire production process including recording, arranging, editing, and
mixing.

This guide assumes that you've installed Logic Express on your computer. If you haven't,
see the Installing Your Software booklet that comes with Logic Express.

You should also connect the music equipment that you plan to use, such as your MIDI
keyboard, audio interface, musical instruments, or microphone, to your computer. For
full details, see the “Setting Up Your System” chapter in the Logic Express User Manual.
(Open Logic Express, choose Help > Logic Express Help, then click Logic Express 9:
User Manual.)



Opening the Demo Project

While you can use your own projects to support the tasks in this guide, many of the
tasks from Chapter 4 onward reference the contents of “The Numbers Game,” a demo
project taken from Thievery Corporation’s fifth studio album, Radio Retaliation, and
featuring Chuck Brown.

To open “The Numbers Game” demo project:
Open Logic Express, then choose Help > Exploring Logic Express Demo Project.

Using Key Commands

You can execute nearly every Logic Express function with a computer keyboard
shortcut, known as a key command. This book includes references to those key
commands that have default computer keyboard shortcuts, using the U.S. and
“U.S. with Numeric Keypad” keyboard presets.

You can use the Key Commands window to assign key commands to your computer
keyboard, allowing you to suit your own working style.

To open the Key Commands window:
Choose Logic Express > Preferences > Key Commands in the main menu bar (or press
Option-K).

Full details on the Key Commands window are found in the Logic Express User Manual.
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Building a Basic Project

This chapter gets you up and running with Logic Express in
the shortest possible time.

If you are new to digital music production, you can use this chapter to learn how to use
the basic features of Logic Express to build a simple music project from scratch.

Creating a Project
You'll start by opening Logic Express and creating a new project, then you'll save it.

Open Logic Express and create a new project:
1 Double-click the Logic Express icon in your Applications folder.
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2 In the Templates dialog that appears, click the Empty Project button.

Empty Project button

3 In the New Tracks dialog, select the Software Instrument option, then click the Create
button.

Chapter 2 Building a Basic Project



Understanding Tracks and Regions

An audio track is a lane in the Arrange area that is used for the playback, recording,
and editing of audio regions.

An audio region is a rectangular object that resides on an audio track. It can be freely
edited and its boundaries correspond to start and end points within the underlying
audio file it is associated with.

A software instrument track is a lane in the Arrange area that is used for the playback,
recording, and editing of MIDI regions, which play internal software instruments.

A MIDI region is a rectangular object that resides on a software instrument track. It
contains MIDI events—individual notes or commands—that are generally created
with a MIDI keyboard.

Chapter 2 Building a Basic Project



After creating a project, you can quickly save it. When you save a project, a project file
is saved within a project folder—which can contain the project’s audio files and other
assets (such as sample and movie files). Saving a project with assets simplifies archiving
and exchanging projects but increases the project folder’s size.

Save the project:
= Choose File > Save As in the main menu bar (or press Command-Shift-S), make the
following selections in the Save As dialog, then click Save.

Ensure that the
Include Assets and
“Copy external audio files
to project folder”
checkboxes are selected.

Type a project name.

Browse to a save location.

Selecting additional
options increases the
project folder’s size.
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Exploring the Arrange Window

The Arrange window is the primary working window of Logic Express. It incorporates all
working areas and editors, including the Arrange area.

The Arrange area is the primary working space of Logic Express. It is used to record,
edit, and arrange the audio and MIDI regions of a project.

Your Arrange window should look similar to this:

Inspector button Media button
) le # My New Project - Arrange
“} Toolbar
e
—— Library tab
e | T @ Eooum e -
i E 305 ymesizers -
i cates e
e e -
e o e
o Transpose: (| (£210 World »
et (312 Logic Basics. >
e pe: L (5313 Surround »
’,""‘“’ AL 14 G4 Optimized. »
e — g“““:‘w"" -
=
| o |
—_— Arrange area
- — .
Lod L (white frame
=
O §o indicates key
focus area)
]
=2 mmrm T
SN | steree Out v .
e — . Editor buttons

Inspector Transport bar
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Try This

Explore the Inspector:

Click the Inspector button to hide or show the Inspector. The Inspector shows
parameters for the selected working area or editor. For example, if the Arrange area
is active (indicated by a white frame), you can set region and track parameters. Also
shown are the channel strips that reference the selected track in the Arrange area.

Click the Score button at the bottom of the Arrange area. The Inspector now shows
parameters that are relevant to working in the Score Editor.

Click the Arrange area. The Inspector again shows parameters and channel strips that
are relevant to working in the Arrange area.

Click the disclosure triangle to the left of MIDI Thru at the top of the Inspector. This
shows or hides the area where you set parameters for the selected region in the
Arrange area.

Click the disclosure triangle to the left of Inst 1 at the top of the Inspector. This shows
or hides the area where you set parameters for the selected track in the Arrange area.

Get to know the toolbar:

Control-click the toolbar, then choose Customize Toolbar from the shortcut menu. This
dialog shows the full list of functions accessible from the toolbar. You can access or
hide certain onscreen areas, such as the Media or Lists area, or carry out key functions,
such as zooming the track and splitting regions.

14 Chapter 2 Building a Basic Project



View the editors:

Click the Sample Editor, Piano Roll, and Score buttons at the bottom of the Arrange
area. Clicking these buttons shows or hides the editors—where you edit audio and
MIDI regions.

Click the Mixer button. This shows or hides the area where you mix your project.

Get to know the Transport bar:

Control-click the Transport bar, then choose Customize Transport Bar from the shortcut
menu. This dialog shows the full list of functions accessible from the Transport bar. You
use the Transport bar to control recording and playback functions.

Explore the Media area:

Click the Media button at the top right of the Arrange window. This shows or hides the
Media area—where you access audio and MIDI files, either your own or prerecorded.
Click the Bin tab to reveal an area that is used for project audio file and region
management and conversion tasks.

Click the Loops tab to reveal an area that contains prerecorded loops for adding to
your project.

Click the Library tab to reveal an area that is used to handle all settings files for channel
strips, effects, and instruments.

Click the Browser tab to reveal an area that is used to browse, select, and manage all
media types supported by Logic Express.

Chapter 2 Building a Basic Project 15
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Playing Instruments
You can use the Library to insert an instrument, plus its effects, into a track’s channel
strip. This allows you to play the instrument from the selected track.

Getting Ready
Click the Library tab in the Media area if the Library is not open.

Try This

Load an instrument (plus its effects):

Navigate through the categories and subcategories in the Library, then click any of the
entries (known as settings).

The chosen instrument and its effects are loaded to the selected track’s channel strip in
the Inspector.
Use your MIDI keyboard (or the Logic Express Caps Lock keyboard) to play some notes.

Chapter 2 Building a Basic Project



Use the Caps Lock keyboard to generate MIDI notes:
1 Press the Caps Lock key on your computer keyboard to reveal a virtual keyboard on
the screen.

2 Use your computer keys as follows to generate MIDI notes:
+ Use the numeric keys to define the octave for the MIDI keyboard.
« Use the first two rows of letter keys as counterparts for MIDI keyboard keys.
* Use the lowest row of letter keys to set MIDI note velocity.
« Use the Space bar for the Sustain function.

Chapter 2 Building a Basic Project
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Adding Apple Loops

You can start composing a song by dragging Apple Loops from the Loop Browser
to the Arrange area. Apple Loops are prerecorded musical phrases or riffs that are
available in a variety of instruments, genres, and moods.

There are two types of Apple Loops—Apple Loops audio files and software instrument
Apple Loops files—and you can add them to your project in the following ways:

» Add Apple Loops audio files to audio tracks. The resulting audio region on the track
contains the original audio recording.

Add software instrument Apple Loops files to software instrument tracks. The
resulting MIDI region contains the original MIDI performance, with its instrument and
effect settings added to the track’s channel strip.

Add software instrument Apple Loops files to audio tracks. The resulting audio region
contains the original audio recording, without the instrument and effect settings.

Chapter 2 Building a Basic Project



Getting Ready
Open the Loop Browser:
= Click the Loops tab in the Media area, then click one of the category buttons.

Reset button View buttons

— Search field

I Category buttons

I Green labels indicate software
instrument Apple Loops files.

I— Blue labels indicate Apple Loops
audio files.
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Try This
Preview Apple Loops:

= Click any loop at the bottom of the tab to start playback. A second click stops playback.
Repeat this for different loops.
Add a software instrument Apple Loops file:

1 Click the Reset button in the Loops tab to reset any active category button selection.

2 Click the Rock/Blues category button, locate Classic Rock Steel 01, then drag the loop
onto the Inst 1 track, aligning its start position at bar 1.

A MIDI region is added to the track. The MIDI region contains the original MIDI
performance, with its instrument and effect settings added to the track’s channel strip.

Effects

MIDI region

j

Setting

- -

|8

|l

Instrument
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Search for a software instrument Apple Loops file:

Click the Reset button, type “Woody Latin Bass 01" in the Search field, then press the
Return key.

—_

The matching file is displayed in the file list.

CE T e [ Gy [ s |
I e —— T
1] | sese oy T] (@ Woody Latin Bass 01 &-—— Search field
= Reset @]  Acoustic Bass. All Drums
Favorites 8 Electric Guitars. Kits.
All Clean. Piano. Beats
Rock/Blues. Distorted Elec Piano Shaker
Electronic Dry Organ ‘Tambourine
wertd Procasssa symns Percussion
Urban Grooving strinas e
Jazz. Melodic Horn Timpani
Country Relaxed Woodwind Cymbal
Cinematic Intense. Brass Vinyl
Orchestral Cheerful Mallets. FX
Experimental Dark Vibes »
[ Name 4] Tempo | Key | Beats | Match | Fav |
—+—— Search result

2 Drag Woody Latin Bass 01 into the empty Arrange area, to start at bar 1.

A new software instrument track is created, with the loop added to it.

Chapter 2 Building a Basic Project 21



Add an Apple Loops audio file to your project:

Click the All Drums button, then drag Live Edgy Drums 05 into the empty Arrange area,
to start at bar 1. A new audio track is created, with the original audio recording added
toit.

¥ Global Tracks

1 ™™™ Steel String Aco.

"™ Upright Jazz Bass

2 MR e gy o (11 () o) [ D 2= Audio region

Add a software instrument Apple Loops file to an audio track:

Click the Reset button, followed by the Elec Piano button, then drag Fusion Electric
Piano 01 onto the existing audio track lane, directly after Live Edgy Drums 05.The
software instrument Apple Loops file is added as an audio region, containing the
original audio recording.
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Browse Apple Loops by category:
1 Click the left View button to switch to Column view.

Click here to switch to
Column view.

2 Click the By Genres category folder, followed by Electronic in the second column,
followed by Beats in the third column.
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The value in brackets indicates the number of files that fall into this subcategory
(Beats). The files are shown at the bottom of the tab.

Tag Apple Loops as Favorites:

= For any Apple Loops that you like, or wish to use again later, select the Fav (Favorites)
checkbox.

[ |_Ra it |

i '] Termpo | Key | Beats | Match | #ev. |

This adds the loop to the Favorites category, displayed whenever you click the Favorites
button or category.
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Navigating the Project

You control navigation and playback actions with the Transport bar or Bar ruler.

« Transport bar:

* Bar ruler:

() ] ] e kv o hegion v ARG Aol e ),

P e e —

Bar ruler

¥ Global Tracks ¥ L

1 ™™ Sicel String Aco.

T Upright Jazz Bass

Playhead (indicates the
current playback position.)

The Transport bar and Bar ruler are closely tied to each other, with several functions
accessible in both. These include the Play and Stop commands, activation of Cycle
mode, and setting the cycle length.

Chapter 2 Building a Basic Project
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Try This
Start and stop playback:

= Click the Play button on the Transport bar (or press the Space bar on your computer
keyboard) to start playback.

Stop button Play button

= Click the Stop button on the Transport bar (or press the Space bar) to stop playback.

= Double-click the lower part of the Bar ruler to start playback from the clicked position.
Another double-click stops playback.

& [@] [#] W] [Edix_v] Track v  Region v| MiDI v Audic v \

b Global Tracks i

Double-click the lower part
of the Bar ruler.

1 .

Steel String Aca.
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Move the playhead:
Click the lower part of the Bar ruler to move the playhead to the clicked position.

Drag the playhead to a new position.

Press the Return key when the project is not playing. The playhead moves to the
project start position.

Click the Rewind or Forward button on the Transport bar during playback.

Rewind button

Forward button

With each click, the playhead either jumps back to the previous bar (Rewind) or ahead
to the next bar (Forward).

Chapter 2 Building a Basic Project
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Loop playback of a project section:

1 Click the shaded gray cycle area in the top part of the Bar ruler.

e iuio oo Auiomaiun bk el ocators iepeai deciing.  Ciop SpiL by iayiea.

2 [0 ) [ [ e [ Agion s WL v [ Ao s
Snap: | Smart | prag:

[owrap 7] (K.

» Global Tracks ar

Click here to activate
the cycle.

The cycle range is activated between the left and right locator positions

Left locator Right locator

s Ciop s sy aidyieas

.\ (@) [, [, (e~ e

v Region v MIDI v  Audio v

» Global Tracks

2 Drag the left or right locator in the Bar ruler to extend or shorten the cycle range.
3 Press the Space bar to start playback.

The playhead continually loops playback within the cycle range.
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Setting the Project Tempo

New projects default to a project tempo of 120 bpm or to the native tempo of the first
Apple Loops file added. When you add subsequent Apple Loops, they automatically
play at the project tempo. You can adjust the tempo to suit the style or mood of

your music.

Tempo display

Mo Out

Try This
Set the project tempo:
Press the Space bar to start playback of the project.

Drag the Tempo display vertically—upward for a faster tempo or downward for a
slower tempo.

The project tempo changes in real time, making it easier to find the most suitable
tempo for your project.

Chapter 2 Building a Basic Project



30

Exploring the Audio Bin
The Audio Bin can be viewed as an audio file catalog for your project. Once an audio
file has been added to your project, it appears in the Bin.

Getting Ready

Open the Bin:

Click the Bin tab at the top of the Media area (or press the B key). The two Apple Loops
audio files you added to the audio track in the previous section appear in the Bin.

Suuie Reguns_bounce Lowia L oies iata insuia

3items selected

K] Infa
S I e 0 L e

Live Edgy Drums 05 = |
e Edgy Drums 051

The Info column displays audio file and region information. The horizontal bars indicate
the overall audio file length. The colored sections of these bars indicate the location
and size of audio regions within the audio file.

Try This

Import an audio file into the Bin:

Choose Audio File > Add Audio File, browse to a location where you'll find an audio file,
click the Add button, then click the Done button. The audio file is added to the Bin.

Add an audio file to the Arrange area:
Drag the audio file you just imported from the Bin into the Arrange area.
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Choosing Tools

Key to selecting and altering audio and MIDI regions in the Arrange area are the tools.
You change the currently active tool by choosing the appropriate Tool menu item.
The pointer adopts the shape of the selected tool, making it easy to recognize. In this
section, you'll assign tools that can be accessed via left-clicking or Command-clicking.

Ay iy e

'4“5—4— Left-click Tool menu

1 n, + |

.-%—5— Command-click Tool menu

Try This
Choose a tool:

i

= Click the Left-click Tool menu at the upper right of the Arrange area, then choose a tool.

= Press the Esc key on your computer keyboard. The Tool pop-up menu floats at the
current pointer position. Choose a tool from the pop-up menu to make it active. Press
the Esc key twice more to make the Pointer tool active.

Chapter 2 Building a Basic Project
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81| . oimerToot
"\, Pencil Tool

& Eraser Tool

I retent

Ip scissors Tool

% Glue Tool

) Soo Tool

@ vute Tool

Q_ zoom Toot

B Crosstade Tool

R, Automation select Tool
N et carve Tl
~+ Marquee Tool

Wt Flex Toal

Click the Command-click Tool menu at the upper right of the Arrange area, then
choose a tool. A second tool is assigned for use via Command-click.

Zoom regions:

With the Zoom tool selected, drag across the Classic Rock Steel 01 region. The screen is
zoomed in on the selected area.

With the Zoom tool selected, click anywhere in the Arrange area background. The
zoom level returns to the original setting or backtracks through previous zoom steps if
the tool was used multiple times.

Tip: If the Zoom tool is not assigned in the Tool menu, holding down the Control and
Option keys provides quick access to the zoom in and out behaviors just described.
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Creating a Basic Arrangement

You'll do the majority of region editing and arrangement in the Arrange area. Besides
standard copy, cut, and paste operations, you can move, delete, loop, and resize regions,
and more.

Try This

Move regions:

Using the default Pointer tool, drag Woody Latin Bass 01 to bar 5 and Live Edgy Drums
05 to bar 9.

Delete a region:

Select the Fusion Electric Piano 01 audio region on the audio track, then press the
Delete key. The region is deleted from your arrangement but not from the project. Click
the Audio Bin tab and you'll find that the region is still there.

Loop regions:
Drag the upper-right corner of the Classic Rock Steel 01 region to the right (note the
Loop pointer), up to bar 9.

|| == (@] [ & | [ M| [Edit v Track v Region v MIDI v  Audio v View v| s St ), prage [
» Clobal Tracks wa
1 s steel String Aco. [R] [M](5] mmw LOOp pOinter
Upright Jazz Bass a P
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= Drag across the other two regions to select them, then select the Loop checkbox in
the Inspector’s Region Parameter box. The two selected regions loop to the project end.

Region Parameter box

Loop checkbox

Tip: Press the L key to quickly loop or unloop selected regions.
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Change the length of regions:
= Drag the lower-right corner of the Woody Latin Bass 01 region from bar 9 to bar 7. The
looped regions are also resized in length.

T T e ] e

Resize pointer
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Exploring a Track’s Channel Strip

A track’s content is played back through a channel strip.

« Audio channel strips control the playback and recording of audio signals on audio tracks.

« Instrument channel strips allow you to use and control software instruments. Software
instrument plug-ins are inserted into the channel strip’s Instrument slot. The
instrument channel strip can then be driven by a recorded MIDI region, or by direct
MIDI input—playing your MIDI keyboard.

You'll explore some of the channel strip controls that are used when playing back a

track’s content through a channel strip.
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Getting Ready
Display a track’s channel strip:

= Select any software instrument track in the Arrange area, and activate the Inspector
button (or press the | key).

Insert slot

Instrument slot (instrument
channel strips only)

Pan/Balance knob
Volume fader

Mute button

Solo button

Chapter 2 Building a Basic Project
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Try This
Mute and unmute channel strips and tracks:
Click the channel strip Mute (M) button. The track Mute button is also activated.

Click the track Mute button (or press Control-M). The channel strip Mute button is also
activated.

Drag over the Mute buttons of several tracks. They are all activated in one swipe.
Command-click the track Mute button. The mute state of all Mute buttons is cleared.
Solo and unsolo channel strips and tracks:

Repeat each of the previous tasks but this time using the channel strip Solo (S) button
and the track Solo button (or pressing Control-S).

Adjust the volume level of a channel strip:

Drag the channel strip’s Volume fader up or down.

Option-click the Volume fader. The Volume fader is reset to the default value.

Adjust the panning or balance of a channel strip:

Drag the Pan/Balance knob vertically or horizontally.

Option-click the Pan/Balance knob. The Pan/Balance knob is reset to the default value.
Open an existing plug-in:

Double-click any used Insert slot or Instrument slot on the channel strip. The plug-in
window of the inserted effect opens.
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Exporting the Project

To share your music project, you can export it in various audio file formats such as MP3
or AIFF. You can also add it directly to your iTunes library. This export process is known
as bouncing.

Try This
Bounce your mix:
Click the Bounce button in the top right of the Arrange toolbar.

Chapter 2 Building a Basic Project
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2 In the Bounce dialog, choose your settings for MP3 file creation:

Note: If the cycle is active, only the project section spanned by the cycle area is
exported. You can change this by editing the Start and End fields in the Bounce dialog.

3 Select the “Add to iTunes library” checkbox to add the file to your iTunes library.
4 Click the Bounce button.

The project section is bounced.
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Key Concepts

* Project: A Logic document. It contains all MIDI regions and references to the audio
files to be played back. A project file is saved within a project folder, which can
contain the project’s audio files and other assets (such as video and sample files).
Saving a project with assets simplifies archiving and exchanging projects but
increases the project folder’s size.

Audio track: A lane in the Arrange area that is used for the playback, recording, and
editing of audio regions.

Audio region: A rectangular object that resides on an audio track. It can be freely
edited, and its boundaries correspond to start and end points within the underlying
audio file it is associated with.

Software instrument track: A lane in the Arrange area that is used for the playback,
recording, and editing of MIDI regions, which play internal software instruments.

MIDI region: A rectangular object that resides on a software instrument track. It
contains MIDI events—individual notes or commands—that are generally created
with a MIDI keyboard.

Arrange window: The primary working window of Logic Express. It incorporates all
working areas and editors, including the Arrange area.

Arrange area: The primary working space of Logic Express. It is used to record, edit,
and arrange the audio and MIDI regions of a project.

Inspector: Area at the left edge of the Arrange window and editors, containing the
Parameter boxes and channel strips of the selected track.

Toolbar: Area at the top of the Arrange window where you can access or hide certain
onscreen areas or carry out key functions.

Chapter 2 Building a Basic Project 4
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« Editors: Areas below the Arrange area where you can edit audio and MIDI regions, or
mix your project.

Transport bar: Area at the bottom of the Arrange window where you can control
recording and playback functions.

Media area: Area containing several tabs where you can access audio and MIDI files,
either your own or prerecorded.

Bin tab: Tab within the Media area that is used for project audio file and region
management and conversion tasks.

Loops tab: Tab within the Media area that contains prerecorded loops for adding to
your project.

Library tab: Tab within the Media area that is used to handle all setting files for
channel strips, effects, and instruments.

Browser tab: Tab within the Media area that is used to browse, select, and manage all
media types supported by Logic Express.

Instrument slot: A panel on a channel strip where you insert an instrument plug-in.

Insert slot: A panel on a channel strip where you insert an effect plug-in.

Bar ruler: Ruler at the top of the Arrange area. It displays musical time units, including:
bars, measures, beats, and beat divisions.

Playhead: A vertical white line that indicates the current playback position in all
horizontal, time-based windows.

Left and Right locators: Locators that define the start and end points of a cycle range
in the Bar ruler.

« Cycle function: A function that constantly repeats the area between the left and right
locator positions.
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* Apple Loops: Prerecorded audio and MIDI-based files located in the Loop Browser.
 Channel strip: A virtual representation of a mixing console channel strip. Contains
Mute and Solo buttons, Volume fader, Pan/Balance control, Insert slots, and more.

* Audio channel strip: Controls the playback and recording of audio signals on an audio
track.

* Instrument channel strip: Allows you to use and control software instruments.
Software instrument plug-ins are inserted into the channel strip’s Instrument slot. The
instrument channel strip can then be driven by a recorded MIDI region or by direct
MIDI input—playing your MIDI keyboard.

Chapter 2 Building a Basic Project
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Working with Instruments 3
and Effects

Logic Express provides a number of ways to add instruments
and effects to your channel strips.

Channel strips contain Insert slots, which are used for inserting effects. Effects color

or shape the tone of existing audio recordings, software instruments, and external
audio sources in real time. Instrument channel strips also feature an Instrument slot,
which is used for inserting instruments. Instruments are used for real-time playback in
Logic Express.

Insert slots

Instrument slot (instrument
channel strips only)
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You can choose whether to insert effect and instrument plug-ins on an individual
basis, directly on the channel strip’s Insert and Instrument slots, or to load channel strip
settings. You'll experiment with both methods in this chapter.

Adding Individual Instruments and Effects
In this section, you'll add instrument and effect plug-ins directly on the channel strip.

Getting Ready
Create a software instrument track and display the Inspector:
Do one of the following:

-y

« If you are using an existing project, click the Add (+) button above the track list, select
the Software Instrument option in the New Tracks dialog, then click Create.

P Clobal Tracks

« If you want to create a new project, see Chapter 2 for details.

N

If the Inspector is not visible, click the Inspector button in the Arrange toolbar (or press
the | key).

666
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Try This
Insert an instrument into a channel strip:

= Click the Instrument slot on the left Arrange channel strip, then choose any instrument
from the plug-in menu. The plug-in is loaded and the window opens. Use your MIDI
keyboard (or the Logic Express Caps Lock keyboard; see Chapter 2) to play some notes.

Instrument slot with
instrument plug-in loaded

Chapter 3 Working with Instruments and Effects
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Insert an effect into a channel strip:
= Click the top Insert slot on the left Arrange channel strip, then choose any effect from
the plug-in menu. The plug-in is loaded and the window opens.

Insert slot with effect
plug-in loaded
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Insert an EQ into a channel strip:

= Double-click the EQ area at the top of the left Arrange channel strip. A Channel EQ is
automatically inserted into the first available Insert slot if the top one is already used,
which it would be if you've followed the previous steps.

g[
}

Setting

T
B

| EQ area

Inserts

=
]
8

Insert slot with Channel EQ
loaded

L
il

You can also Option-double-click the EQ area to insert the Channel EQ as the first plug-
in, moving all existing plug-ins one slot down.

|

Setting

|2

il
Il

Replace a plug-in:

= Click and hold down any occupied Instrument slot or Insert slot, then choose a
different plug-in from the respective pop-up menu. If a plug-in window is already open,
it updates to reflect the new plug-in. Otherwise, a new plug-in window opens.
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Remove a plug-in:
= Click any occupied Instrument slot or Insert slot, then choose No Plug-in from the pop-
up menu. The plug-in is removed from the slot, leaving it empty.

Deactivate a plug-in without removing it:
= Option-click the occupied Instrument slot or Insert slot. The slot turns from blue to gray,
which indicates that the plug-in is on the channel strip but no longer active.

-Setting. |
Inserts
Bypassed plug-in
—_—

Sends

= Double-click the occupied Instrument slot or Insert slot, then click the Bypass button at
the left of the plug-in window header.

Eypass
!

Indicates an Indicates a
active plug-in. bypassed plug-in.
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Working with Plug-in Settings

A plug-in setting is a set of plug-in parameter values that can be loaded, saved, copied,
or pasted via the Settings menu.

~ Show Channel Strip + Show Insert

Compare | 4% #default

Click here to access the
Settings menu in the
plug-in header.

Plug-in settings are stored with the project file and are automatically recalled the next
time the project is loaded. You can change these settings individually by adjusting
individual parameters or by loading an entire setting for the plug-in. You can also save
and recall any changes you make to plug-in settings.

Getting Ready
Open a plug-in window (if one is not already open):
= Double-click any occupied Instrument slot or Insert slot.

Chapter 3 Working with Instruments and Effects
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Try This
Adjust individual plug-in settings:
= Adjust individual controls in any open plug-in window.
« Click switches or buttons to turn the parameter on or off.
« Drag knobs vertically to adjust the parameter value.
« Drag slider handles to adjust the parameter value.
» Option-click a parameter to reset it to the default value.
Save the new plug-in settings:
= Choose Save Setting As from the Settings menu, type a name for the new setting, then
click Save. A new entry (with the name you entered) is added to the Settings menu, just
above the list of presets.
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Load a setting:
= Choose a different setting from the list of presets at the bottom of the Settings menu.

= Reload the setting you saved previously from the Settings menu.

= Click the Next or Previous Setting buttons in the plug-in header. The next or previous
setting from the list of presets is loaded.

Q
&7 [View T Show Chassel Stlp—=— Previous Setting button

Eypass

Next Setting button

= Click any occupied Instrument slot or Insert slot. A white frame appears around the slot,
and the Library tab updates to display a list of settings (preset patches) for the chosen
plug-in. Choose a different setting to load it for the selected plug-in.

o[ e | Ubay | owser

(@ Search Library 3

7 112 Note Dotted Feadback
5 112 Note Dotted

= 112 Note Flutter

77 114 Note Dotted

5 114 Note Feedback.
7 114 Note Flutter

4 118 Note Dotted Dub
4 118 Note Dotted
[“Seuing | | [“Sesting | 5 118 Note Fiutter
P = 118 Note Triplet

= 1116 Nate Dotted

Bt A

ChanEQ — 4 1116 Note Feedback
[Tape m— 4 1116 Note Slap
— 77 1116 Note Triplet

Sends = Uhra Dub
 S—
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Loading Channel Strip Settings

You can load a whole chain of plug-ins using channel strip settings. When you load a
channel strip setting to an audio channel strip, you load a chain of effects. In the case of
instrument channel strips, you load an instrument and a chain of effects.

Channel strip settings can be accessed from the Setting button directly on the channel
strip or from the Library tab in the Media area.

Getting Ready
Select a software instrument track and open the Library:
1 Select the software instrument track used in the previous section.

2 Click the Library tab in the Media area if the Library is not open.

54 Chapter 3 Working with Instruments and Effects



Try This
Load a channel strip setting from the Library:

1 Navigate through the categories and subcategories in the Library, then click any of the
entries (known as settings).

The Setting button, Insert slots, and Instrument slot on the left Arrange channel strip
are updated to reflect the channel strip setting and its effect and instrument plug-ins.

Setting button

Insert slots

Instrument slot

2 Use your MIDI keyboard (or the Logic Express Caps Lock keyboard; see Chapter 2) to
play some notes.

Chapter 3 Working with Instruments and Effects
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3 Repeat steps 1 and 2, trying out different channel strip settings. Play some notes on
your keyboard after each change of setting.

Load a channel strip setting in the Arrange channel strip:
= Click and hold down the Setting button in the left Arrange channel strip, navigate
through the setting categories and subcategories, then click one.

(somniey | o | ]

o Seventies Kit.cst

Next Channel Strip Setting 01
Previous Channel Strip Secting &1

Copy Channel Strip Setting  TEC
Paste Channel Strp Seting L&V
Reset Channel Strip

Save Channel Strip Setting as..
Save as Performance..

Delete Channel Strip Setting

01 Acoustic Pianos.

04 Keyboards.
05 Synthesizers
06 Pop Strings
08 Guitars

09 Orchestral
10 World

12 Logic Basics
13 Surround

14 G4 Optimized

Y YYTYVYYVYYYYYY

GarageBand

The Setting button, Insert slots, and Instrument slot on the left Arrange channel strip
are updated to reflect the channel strip setting and its effect and instrument plug-ins.
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Select the previous or next channel strip setting:

Click the Setting button in the left Arrange channel strip, then choose Previous Channel
Strip Setting or Next Channel Strip Setting from the pop-up menu. The Setting button,
Insert slots, and Instrument slot on the channel strip are updated to reflect the new
setting.

Save and recall a channel strip setting:

Navigate through the categories and subcategories in the Library, then click any of the
entries.

The Setting button, Insert slots, and Instrument slot on the left Arrange channel strip
are updated to reflect the channel strip setting and its effect and instrument plug-ins.
Click the left Arrange channel strip’s third Insert slot, then choose Amps and Pedals >
Amp Designer. The Amp Designer plug-in window opens. Change some settings.

Click the channel strip’s Setting button, choose “Save Channel Strip Setting as” from the
pop-up menu, type a name for the channel strip setting in the dialog, then click Save.
Click the channel strip’s Setting button, then choose a different setting from the pop-
up menu.

Your channel strip setting is replaced with the new one.

Click the Setting button, then choose your previously saved channel strip setting from
the pop-up menu.

Your previously saved setting is recalled.

Reset a channel strip setting:

Click the Setting button in the left Arrange channel strip, then choose Reset Channel

Strip from the pop-up menu. In a single action, the channel strip setting name, the
Instrument slot, and the Insert slots are reset to their default values.
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Key Concepts
« Channel strip: A virtual representation of a mixing console channel strip. Can be used
to insert instruments and effects using the channel strip’s Instrument and Insert slots.

Instrument slot: A panel on a channel strip where you insert an instrument plug-in.

Insert slot: A panel on a channel strip where you insert an effect plug-in.

Effects: Color or shape the tone of existing audio recordings, software instruments,
and external audio sources, in real time.

Instruments: Used for real-time playback in Logic Express.

Channel strip setting: Represents the routing of a channel strip, including all inserted
effects or instruments (plus their settings).

Library tab: Tab within the Media area that is used to handle all setting files for
channel strips, effects, and instruments.

EQ: Shortened form of equalizer. Equalizers are used to boost or cut frequencies in an
audio signal.
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Recording and Comping Audio

You can record and comp audio directly in the Arrange area.

In this chapter, you'll try out some basic audio recording techniques and experiment
with take folder editing and comping.

Setting the Metronome and Count-in
As preparation for recording, you should check the metronome and count-in settings.

» Metronome: Produces a click in the project’s tempo that can be heard during
recording or playback. The click makes it easier to play in time with the tempo.

* Count-in: Clicks heard before the start of a recording, making it easier to get into the
project’s groove.

Try This

Set the metronome:

Control-click the Metronome button on the Transport bar, then choose Metronome
Settings from the shortcut menu.

L) ' ' @ I. Metronome button
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2 In the Metronome pane, define when you want to hear the metronome click—on every
bar, beat, or division—by selecting the corresponding checkboxes.

3 Select the “Click while recording” and “Only during count-in” checkboxes.

This allows you to hear a count-in of 1 bar before recording begins. If you want to
change the default count-in setting, see the following task.
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Change the count-in:

= Click the Recording button in the Project Settings window. In the Recording pane,
choose an option from the Count-in pop-up menu. You can record without a count-in,
set a count-in of a specific amount of bars, or set a count-in time signature.

Chapter 4 Recording and Comping Audio
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Making an Audio Recording
When you make a single audio recording, an audio region that displays a graphical
overview of the waveform is created on the selected Arrange track.

Getting Ready
Create a new audio track:

= |f you're using an existing project, click the Add (+) button above the track list, select
the Audio option in the New Tracks dialog, then click Create.

¥ Clobal Tracks

= |f you want to create a new project, see Chapter 2 for details.
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Set up a channel strip’s track for recording:
Click the Input slot of the left Arrange channel strip to choose the input for the
connected instrument.
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If you want, you can add effects that fit your instrument to the channel strip. For
example, if you want to record a guitar, click the top Insert slot of the left Arrange
channel strip, then choose Amps and Pedals > Amp Designer from the pop-up menu.
Repeat the steps for Insert slot 2, choosing Pedalboard from the pop-up menu.

Turn on the Input Monitoring button.

This allows you to hear incoming audio, even when the track is not record-enabled
(useful for setting audio levels or practicing before recording). Play your guitar and you
should hear it as well as see the level meters moving on the left Arrange channel strip.
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Try This
Record an audio track:
Click the selected audio track’s Record Enable button.

The track is ready for recording.

Click the Record button on the Transport bar to start recording. You can also press the
Asterisk (*) key on keyboards with a numeric keypad, or the R key on other keyboards.

Record button

Recording will begin after the predefined count-in.

3 Play your instrument.

4 Click the Stop button on the Transport bar (or press the Space bar) to stop recording.

Stop button

The selected audio track contains a new audio region that displays a graphical
overview of the waveform.
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Recording Audio Takes

When you record over a pre-existing region, Logic Express creates what is called a take
folder, which contains multiple take regions. A common scenario is when you record
multiple passes while in Cycle mode; for example, if you are recording multiple versions
of a solo. You can also do this by simply recording over an existing region.

Note: Make sure that the Replace button on the Transport bar is turned off.

Replace button

Getting Ready

Create a cycle based on an existing region:

Select the audio region that you recorded in the previous section, and click the Set
Locators button in the Arrange toolbar. Cycle mode is turned on, with the left and right
locators set to match the audio region start and end points.

Left locator Right locator
P REC - Arrange

=| = 4 B

Set Locdtors Repeat Section Crop ~Split by Pigyhead

= Track | Region v MIDI v Audio v i
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Try This
Record multiple audio takes:
Press the Return key.

—_

The playhead moves to the project start position.
2 Press the Asterisk (*) or R key to start recording.
Recording begins after the predefined count-in.
3 Play your instrument and record as many cycle passes as you wish.

4 Press the Space bar to stop recording.

The selected audio track contains a take folder with multiple take regions inside.
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Exploring Take Folders

In this section, you'll look at how to open take folders and how to choose individual
takes for playback in your project. You'll also listen to an original comp—the best parts
from several take recordings combined into one master take—in the demo project.

Getting Ready
Open the demo project and set an appropriate zoom level:
Open “The Numbers Game” demo project.

2 Turn on the track Solo button for Track 1: Chuck Vox.

Click anywhere in the Arrange area background to deselect all regions on Track 1:
Chuck Vox, then click the take folder Chuck Vox.3 at bar 23 to select it.

Chorus 2
(P Chuck Vox3: Comp 2 0

Take folder

Click the Set Locators button in the Arrange toolbar to turn on Cycle mode.

5 Holding down Control-Option (which activates the Zoom tool), drag across the take

folder Chuck Vox.3 on Track 1: Chuck Vox to zoom the working area.

Chapter 4 Recording and Comping Audio
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Try This
Open the take folder:

= Double-click the closed take folder Chuck Vox.3 on Track 1: Chuck Vox. The take folder
opens, displaying two takes, Chuck Vox Alt and Chuck Vox 2, on individual lanes. Chuck
Vox 2 is the most recent take.

I— Take folder

I Individual takes

Listen to the current comp:
= Press the Space bar to listen to the current comp selection.
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Choose a take region for playback:
= Click the triangle in the upper-right corner of the take folder, then choose Take 1:
Chuck Vox Alt from the Take Folder pop-up menu.

Click here to open the Take
Folder pop-up menu.

The chosen take is displayed in color (the color is also reflected in the take folder) and
the take that is not selected is displayed in gray.

Chapter 4 Recording and Comping Audio
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= Choose Take 2: Chuck Vox 2 from the Take Folder pop-up menu. Again, the chosen take
is displayed in color (the color is also reflected in the take folder) and the take that is
not selected is displayed in gray.

Creating and Editing Comps

You can select individual take regions for playback in your project. But what if you want
to combine selected parts of each take region for playback—the first section of Chuck
Vox Alt followed by the end section of Chuck Vox 2, for example?

This section shows you how.

Getting Ready

You can switch take folders between two different editing modes, with the active
editing mode determining the types of edits that can be made in the take folder. This
section assumes that the Quick Swipe Comping mode is on, allowing you to create and
edit comps.
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Verify the take folder’s editing mode:

= Make sure that Quick Swipe Comping is active in the Take Folder pop-up menu. You
can also click the icon in the upper-right corner of the take folder so that it looks as
follows:

=1 Icon shows that Quick

T =
= ¢ Take 2: Chuck Vox 2 Swipe Comping mode is
Take 1: Chuck Vox Alt on.

Wl-.:mnpl
Comp 2: Comp 2

Create New Comp
Rename Take
Delete Take
Flatten

Flatten and Merge
Export active Take to New Track
Move active Take to New Track
Unpack

Unpack to New Tracks

¥ Quick Swipe Comping [
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Try This
Create a new comp:

= With Take 2: Chuck Vox 2 selected from the last task in the previous section, place the
pointer over the left edge of Chuck Vox Alt, and drag to the right, as far as bar 30.The
selected area on Chuck Vox 2 is shortened. Playing back the project plays Chuck Vox Alt
to bar 30, followed by the rest of Chuck Vox 2.

When you create a new comp, it is automatically added to the Comp list in the Take
Folder menu (Comp 3 in this case).
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Save the comp:

= Choose Duplicate Comp from the Take Folder pop-up menu. The current comp (Comp
3in this case) is duplicated and the duplicate (Comp 4) becomes the active comp for
any further changes.

Edit the comp:
= Place the pointer over the right edge of the take region Chuck Vox 2, and drag to the
left, as far as bar 35.The end of Chuck Vox 2 is removed from the comp, leaving silence.

Chapter 4 Recording and Comping Audio
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Switch take region selections between takes:
= (Click the area that is not selected at the end of Chuck Vox Alt. The clicked area is
selected and the same area in Chuck Vox 2 is deselected.

Switch back to the saved comp:
= Choose the comp you saved in an earlier task from the Take Folder pop-up menu
(Comp 3 in this case). The comp is reloaded along with the edits you made at that time.
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Editing Take Regions
What if you want to cut a take region into multiple sections, or move these sections
around, or even delete them?

Next you will experiment with each of these tasks.

Getting Ready
This section assumes that the Quick Swipe Comping mode is off, allowing you to cut,
drag, and delete take folder and take region elements.

Change the take folder’s editing mode:
Deselect Quick Swipe Comping from the Take Folder pop-up menu. You can also click
the icon in the upper-right corner of the take folder so that it looks as follows:

Icon shows that

B, Take 2: Chuck Vox 2 Quick Swipe Comping
Take 1: Chuck Vox Alt mode is off.

Comp 1: Comp 1
Comp 2: Comp 2

Create New Comp

Rename Take

Delete Take

Flatten

Flatten and Merge

Export active Take to New Track
Move active Take to New Track
Unpack

Unpack to New Tracks

E Quick Swipe Comping [
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Try This

Cut a take region:

Using Comp 3 from the previous section, select the Scissors tool, then click Take 2 at
bar 35.The take is cut at the clicked position, giving you two separate take regions on
the same lane.

Drag a take region:

Drag the take region—the one you cut in the previous task—from bar 35 to bar 37.The
length of the take folder is extended up to the end point of the take region. Listen to
the playback.

Delete a take region:
Make sure that the take region you dragged in the previous task is selected, then press
the Delete key.
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Managing Take Folder Contents
In this section, you'll experiment with some commands in the Take Folder pop-up
menu that can help with take folder management.

Try This
Export an active comp to a new track:

= Using the current comp in the take folder, choose “Export active Comp to New Track”
from the Take Folder pop-up menu. The active comp is copied to a new track, which
is created below the take folder track. The content of the original take folder remains
intact.

AU I O L L VLU | i
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Crossfades

Crossfades—used to create a smooth transition between two adjacent audio regions
on a track—are visible between the take regions of the exported comp.

Using this command allows you to edit the current comp in the same way as other
audio regions.
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Move an active comp to a new track:

Choose “Move active Comp to New Track” from the Take Folder pop-up menu.The
active comp is moved to a new track, which is created below the take folder track. This
comp is no longer available in the original take folder.

You might use this option when you are ready to commit to a comp but want to keep
all other takes and comps archived in the original take folder.

Flatten a take folder:

Choose Flatten from the Take Folder pop-up menu. The take folder is replaced with
multiple regions that represent the current comp selections. All take region sections
not used in the current comp are deleted.

Use this option when you want to discard all comps and takes other than the current
comp.

You can also use the Flatten and Merge command in the Take Folder pop-up menu to
replace the take folder with a single region that represents the current comp selections.
Use this option when you are ready to fully commit to the comp and don't expect to
make any further edits where the individual comp sections intersect.
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Key Concepts
» Metronome: A click in the project’s tempo that can be heard during recording or
playback. The click makes it easier to play in time with the project’s tempo.

Count-in: Clicks heard before the start of a recording, making it easier to get into the
project’s groove.

Input slot: A panel on an audio channel strip where you assign the channel strip input.

Insert slot: A panel on a channel strip where you insert an effect plug-in.

Input Monitoring: Allows you to hear incoming audio when audio tracks are playing,
record-enabled, or recording.

Take: A recording. Logic Express allows you to create several takes, one after the
other, without leaving record mode.

Take folder: A container for multiple take recordings.

Cycle function: A function that constantly repeats the area between the left and right
locator positions.

Quick Swipe Comping: The behavior of swiping across take sections to create and
edit comps.

Drag editing: The behavior of cutting, dragging, and moving take folder and take
region elements.

Comp: The result of combining selected parts of multiple takes into a single perfect
take.
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Recording MIDI

You can use a MIDI keyboard to record MIDI in real time in
Logic Express.

This chapter focuses on recording options that are specific to recording MIDI in real
time. You'll learn how recording over the top of a previous performance can have
different outcomes—merging recordings, replacing recordings, or creating take
folders—depending on your recording setup. You'll also experiment with quantization,
a process that allows you to correct the timing of MIDI notes.

Making a MIDI Recording

MIDI recording is similar to audio recording. You play your connected MIDI keyboard
and Logic Express automatically records the incoming MIDI events on the record-
enabled MIDI or software instrument track. In this chapter, you'll only record to

a software instrument track. Information about MIDI tracks can be found in the
Logic Express User Manual.

For details about setting the metronome and count-in prior to recording, see Chapter 4.
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Getting Ready
Create a new software instrument track and load a channel strip setting:
Create a new track by doing one of the following:

—_

« If you are using an existing project, click the Add (+) button above the track list, select
the Software Instrument option in the New Tracks dialog, then click Create.

P Global Tracks

1 | nse 1

« If you want to create a new project, see Chapter 2 for details.

2 In the Library tab (Media area), choose a channel strip setting that you will experiment
with while recording.

Instrument and effect settings are loaded to the Instrument and Insert slots on the left
Arrange channel strip.

3 Make sure that your MIDI keyboard is connected.
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Try This

Record a software instrument part:

Click the Record button on the Transport bar to start recording. You can also press the
Asterisk (*) key on keyboards with a numeric keypad, or the R key on other keyboards.

—_

Record button

Recording begins after the predefined count-in.

2 Use your MIDI keyboard (or the Logic Express Caps Lock keyboard; see Chapter 2) to
play some notes.

A MIDI region appears on the software instrument track.

3 Click the Stop button on the Transport bar (or press the Space bar) once you're done.

Stop button Play button

4 Click the Play button on the Transport bar (or press the Space bar) to play back the
recording.
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Quantizing MIDI

If you're not happy with the timing of your performance, you can use the Quantize
feature to correct the timing of MIDI notes to the nearest selected musical time value.
You do this using the Quantize pop-up menu in the Inspector’s Region Parameter box.

Getting Ready
Set an appropriate zoom level for the MIDI region:

= Holding down the Option and Control keys, drag across the MIDI region you recorded
in the previous section.
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Try This

Correct the timing of note events:

Click the Quantize parameter in the Inspector’s Region Parameter box, and choose
1/16-Note from the pop-up menu. Watch how the note events change position in the
MIDI region. This value is generally a good place to start for “duplet” based rhythms
(dividing a beat into two even pieces).

Click the Quantize parameter in the Inspector’s Region Parameter box, then choose “off”
from the pop-up menu. The MIDI note events are returned to their original positions.
Click the Quantize parameter in the Inspector’s Region Parameter box, then choose
1/12-Note from the pop-up menu (which is the equivalent of an 8th note triplet). The
note events move position in the MIDI region. This value is generally a good place to
start for “triplet” based rhythms (dividing a beat into three even pieces).

Chapter 5 Recording MIDI
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Overdub Recording MIDI

Overdubbing is the process of recording a performance in multiple passes, merging
the performances into a single region. You'll experiment with recording multiple MIDI
performances on top of an existing performance.

Try This

Record over an existing MIDI region in Cycle mode:

Click the Set Locators button in the Arrange toolbar.

Cycle mode is turned on and the left and right locators match the start and end points
of the MIDI region you recorded in the previous section.

Left locator Right locator
& REC - Arrange

= | B &4 o

Set Locdtors  Repeat Section Crop  Split by Pidyhead

1 rack | ] Region ] b1 v Jusdia =] e v | [

BT —
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Press the Return key while Logic Express is not playing.
The playhead moves to the project start position.
Press the Asterisk (*) or R key to start recording.
Recording begins after the predefined count-in.

Use your MIDI keyboard (or the Logic Express Caps Lock keyboard) to play some notes.
Record as many cycle passes as you wish.

Press the Space bar to stop recording.
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The end result is a single MIDI region that contains the merged performances from
each cycle pass.

You can also overdub a MIDI recording when not in Cycle mode.

To do this:

1 Control-click the Record button on the Transport bar, then choose Recording Settings
from the shortcut menu.

2 In the Recording pane, choose “Merge with selected regions” from the Overlapping
Recordings pop-up menu.

3 Repeat the recording steps from the last task, but without turning on Cycle mode.
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Replace Recording MIDI
Replace recording is the process of erasing all or part of a previous performance while
recording a new one. You'll do this by recording in Replace mode.

Try This
Record over an existing MIDI region in Replace mode:
Click the Replace button on the Transport bar.

Cycle button

| eee@w >

Replace button

Make sure that Cycle mode is turned on.

3 Press the Return key while Logic Express is not playing.

The playhead moves to the project start position.

Press the Asterisk (*) or R key to start recording.

Recording will begin after the predefined count-in.

Use your MIDI keyboard (or the Logic Express Caps Lock keyboard) to play some notes.
A new MIDI region is created on top of the existing one.

Press the Space bar to stop recording.

Your new recording replaces whatever portion of the previous material you recorded
over, repeating the process for each cycle pass if recording in Cycle mode.
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Recording MIDI Takes

While you will usually want to record multiple cycle passes into a single region, take
recording is also an option.

Take recording allows you to record over an existing performance and results in the
creation of a take folder with each recording inside. A common scenario is when you
are recording multiple passes in Cycle mode, but you can also do this by recording over
an existing region.

Getting Ready

Modify the project setting for MIDI Overlapping Recordings:

Control-click the Record button on the Transport bar, then choose Recording Settings
from the shortcut menu.

In the Recording pane, choose “Create take folders” from the Overlapping Recordings
pop-up menu.
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Try This

Record MIDI takes:

If you want to record in Cycle mode, click the gray shaded area in the top part of the
Bar ruler.

Press the Return key while Logic Express is not playing.
The playhead moves to the project start position.
Press the Asterisk (*) or R key to start recording.
Recording will begin after the predefined count-in.

Use your MIDI keyboard (or the Logic Express Caps Lock keyboard) to play some notes.
Record a single pass or as many cycle passes as you wish.

Press the Space bar to stop recording.
The selected software instrument track contains a take folder with multiple takes inside.

Double-click the closed take folder to view the contents, click the take you want to
hear, then start playback.
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Key Concepts

* Quantization: The process of correcting the timing of MIDI note positions.

* Quantize pop-up menu: A menu in the Region Parameter box that you use to correct
the timing of MIDI notes to the nearest selected musical time value.

MIDI region: A container for MIDI events—individual MIDI notes or commands—that
are generally created with a MIDI keyboard.

Library tab: Tab within the Media area that is used to handle all setting files for
channel strips, effects, and instruments.

Channel strip setting: Represents the routing of a channel strip, including all inserted
effects or instruments (plus their settings).

Overdubbing: The process of recording a performance in multiple passes, merging
the performances into a single region.

Cycle function: A function that constantly repeats the area between the left and right
locator positions.

Replace mode: The process of erasing all or part of a previous performance while
recording a new one.

Take: A recording. Logic Express allows you to create several takes, one after the
other, without leaving record mode.

« Take folder: A container for multiple takes.
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Creating an Arrangement 6

You create an arrangement by dividing, copying, cropping,
repeating, cutting, and inserting regions and region sections.

In this chapter, you'll work with audio and MIDI regions in the Arrange area to create an
arrangement for your song. You'll use the following selection and navigation features.

Left locator Cycle range j Right locator

Marquee tool

P Chuck Vox.3: Comp 2 ©

| Playhead

» Marquee tool: Tool used to select and edit parts of regions by dragging across them.
* Cycle range: Repeated section of a project, shown as a green stripe in the Bar ruler.
« Left and right locators: Define the start and end points of a cycle range in the Bar ruler.

* Playhead: Vertical white line that indicates the current playback position in all
horizontal, time-based windows.
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Previewing the Demo Project

You can't tackle the arrangement until you first get a feel for the content and structure
of the song. You'll preview the contents of the demo project using Solo mode, a mode
in which you can select one or more tracks or regions to hear them in isolation.

Getting Ready
Open the demo project and turn on Solo mode:
1 Open “The Numbers Game” demo project.

N

Click the Solo button on the Transport bar (or press the S key) to turn on Solo mode.

Solo button

The Bar ruler is shaded in yellow, indicating that you are in Solo mode.
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Try This
Preview different tracks and regions in the project:
Click the Play button on the Transport bar (or press the Space bar) to start playback.

Play button

During playback, click individual track headers (or use the Up Arrow and Down Arrow
keys) to hear the entire track play back in Solo mode.

Click individual regions to hear them play back in Solo mode.

Drag across several regions to hear the region selection play back in Solo mode. Drag
across all the horn regions, for example.

When finished, press the S key to turn off Solo mode.
Mute a region:

During playback, select the Mute tool, then click any region. A second click unmutes
the region.

Select a region, then press the M key. Press the M key a second time to unmute
the region.

Chapter 6 Creating an Arrangement
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Dividing Regions
You can slice any region into several parts, thus creating several individual regions. This
allows you to move, copy, and delete parts of your arrangment.

Try This
Divide a region:

= Select the Scissors tool, then click any region at the required cut position. You can also
do this by dragging across the region with the Scissors tool. Scrubbing allows you to
hear the audio at the playhead position, making it easier to cut at the correct position.

Divide a region into multiple portions of equal length:
= Hold down the Option key while cutting a region with the Scissors tool. The selected
region is cut into several pieces—each the same length as the first segment.

Divide a region using locators:
1 Click the shaded gray cycle area in the top part of the Bar ruler.

il kiR b bualuis  epe L ki P

| H | [ Edit v Track »| Region v| MIDI ¥ Audic ~

Click here to activate
the cycle.
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The cycle range is activated between the left and right locator positions.

Left locator Right locator

Bl kiR &b bocions iepealsecion Liop  apiiio

"W | [[Edit v Track [+ Region v MIDI v Audic ~

Drag the left or right locator in the Bar ruler to extend or shorten the cycle range.

Select the region you want to split, then choose Region > Split > Split Regions by
Locators in the local menu bar.

The section of the region located between the locators is cut at the left and right
locator positions.

Divide a region using the playhead:

Drag the playhead to a position where you want to divide a region, select the region,
then choose Region > Split > Split Regions by Playhead in the local menu bar. The
region is divided at the playhead position.

Divide a region using a marquee selection:

Hold down the Command key (which activates the Command-click tool with the
Marquee tool currently assigned) while dragging across a region. Click the marquee
selection area with the Pointer tool to cut the region at the marquee borders.

Try pressing the M key on your computer keyboard instead of clicking the marquee
selection area, as described in the previous task. In addition to the region being

divided, the region that was inside the boundaries of the marquee selection is muted.
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Merging Regions
You can merge two or more selected regions (of the same type—audio or MIDI) into a
single region, making region handling much easier in your arrangement.

Try This

Merge audio regions:

Select the Glue tool, drag to select multiple audio regions, then click one of them.
When Logic Express provides you with the warning that a new audio file will be
created, click Continue.

The selected audio regions become one audio region, with silence added for any gaps
between. A new audio file is added to the Audio Bin.

Merge MIDI regions:
Drag to select multiple MIDI regions, then click one of them. The selected MIDI regions
become one MIDI region, with silence added for any gaps between.
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Copying Regions
You can copy regions or region portions. This allows you to reuse entire regions, or
portions of them, at other parts of your arrangement.

Getting Ready

Set an appropriate zoom level:

Select Track 13: Gtr Fill, then holding down the Option and Control keys (which
activates the Zoom tool), drag across the “Gtr Fill” audio region.

Chorus 1
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Try This
Copy a region section by dragging:
1 Using the Marquee tool, drag to select the area between bars 17731 1and 1733 1.

seuiacaiors nspealsecion Lo apii by iiayneid

Track v ] Region | MiDI +] Audic v] View ~]

GirFil o Gur Fill
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2 Holding down the Option key, drag the marquee selection area, release the mouse

—y

A W N

button at bar 194 1 1 on the same track, then release the Option key.

Lbotaios kepeatsecuon Livp  apuL sy rispaeas ounice i gruna sounce

Snap: [Smart | Drag: [No©

lrack v Region v MIDI v Audio v  View v

CrrAill | ¢ CrFL4O

| | I
|

Copy Regions
13 GrrFil3

The marquee selection area is copied at bar 194 1 1.

Copy a region using edit commands:

Click the Arrange area background to remove the previous marquee selection.
Move the playhead to bar 20.

Select the newly created region Gtr Fill.5 at bar 194 1 1.

Choose Edit > Copy (or press Command-C).

The region is copied.
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5 Choose Edit > Paste (or press Command-V).
The region is pasted at bar 20.

Liocaio ciop b

Track v Region v MIDI v Audio v View v

GrAilo Gl
| | |
111

Copy an entire region:
= Hold down the Option key while dragging any region to another position, only
releasing the Option key after you release the mouse button.
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Cropping Regions
You can remove all parts of a region that fall outside the boundaries of a marquee
selection.

Try This
Crop a region:

1 Select Track 12: Guitar Rev, then using the Marquee tool, drag to select the area
between bars65311and 6631 1.

Lhocaiois Repeatoechon  Livp . apuLsy risyasas

eadke v Region v | MBI v | Aulio v| View v S [

Chapter 6 Creating an Arrangement

103



2 Press Control-C (which activates the Crop Regions outside Locators or Marquee
Selection key command).
The region parts that fall outside the boundaries of the marquee selection are cropped.

Siucaiocs. epeataechon  Ligp obiL oy i nes

$naps |50

frack =

Region v MIDI v Audio v View v

Breakdown

Guitar Rev.6 0
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Editing Arrange Sections

You can remove an entire passage from your arrangement, inserting it elsewhere in the
song, or you can repeat a section of your arrangement. You'll explore these activities
using the demo project.

Getting Ready

Holding down the Option and Control keys (which activates the Zoom tool), click
anywhere in the Arrange area background until the project returns to its original zoom
level setting.

Try This

Repeat a section of the project:

Drag the left and right locators of an active cycle range to select the section of a
project you want to repeat, then choose Region > Cut/Insert Time > Repeat Section
Between Locators in the local menu bar. The entire section that falls within the locator
positions is repeated.

Cut a section from the project:

Drag the left and right locators of an active cycle range to select the section of a
project you want to remove, then choose Region > Cut/Insert Time > Snip: Cut Section
Between Locators in the local menu bar. The entire section that falls within the locator
positions is removed.

Insert a section in the project:
After cutting a section from your project, move the playhead to the position where you
want to insert it, then choose Region > Cut/Insert Time > Splice: Insert Snipped Section

at Playhead in the local menu bar. The entire section is inserted at the playhead position.
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Key Concepts

* Arrangement: The process of organizing your musical material into a song structure.

« Left and right locators: Locators that define the start and end points of a cycle range
in the Bar ruler.

* Playhead: A vertical white line that indicates the current playback position in all
horizontal, time-based Logic Express windows.

* Solo mode: A mode in which you can select one or more tracks or regions to hear
them in isolation.

» Marquee tool: Used to select and edit parts of regions by dragging across them.

» Mute tool: Used to stop a region or region section from playing by clicking it.

* Glue tool: Used to merge regions by selecting and clicking them.

« Scissors tool: Used to divide a region by clicking it.
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Flex Time Editing 7

You can use Flex Time editing functions to edit the timing of
single or multiple audio regions.

This chapter introduces you to the techniques used for Flex Time editing as well as

the track-based settings that detemine how the timing of your audio will be altered.
You'll learn how to correct a single note or the timing of an entire region, all within the
Arrange window.

Flex Time editing greatly simplifies the process required for altering the timing of audio
material. It allows you to compress or stretch the time between specified points in an
audio region without the need for more traditional processes like cutting, nudging, and
crossfading. Though comparable to what is sometimes referred to as elastic audio in
other applications, Flex Time editing provides unique advantages, such as the option to
employ beat slicing methods that do not rely on time stretching algorithms.

Flex Time editing is largely dependent on a set of markers called transient markers,
which denote significant points in an audio file. The audio on a track is analyzed for
transients the first time you enable that track for Flex Time editing. Any detected
transients in the file are marked with transient markers.
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You edit the timing of audio material using flex markers. When you move a flex marker,
it time compresses or expands the area around it. The initial boundaries within which
this is done is determined by the transient markers. You manipulate flex markers either
in the Arrange area’s Flex view, or invisibly using the Flex tool. You can create single or
multiple flex markers in an audio file, enabling you to manipulate the position of single
notes or complete phrases.
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Exploring Flex View and Flex Modes
You'll start by turning on Flex view in the Arrange area and exploring some of the
available flex modes.

Getting Ready

= Open “The Numbers Game” demo project. Track 1: Chuck Vox is selected by default.
Try This
Display Flex view in the Arrange area:

= Choose View > Flex View. Flex view is turned on and the Flex Mode menu is displayed
in the track header of Track 1: Chuck Vox.

Flex Mode menu

¥ Clobal Tracks

b Marker
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Locate the available flex modes:
= Click the Flex Mode menu in the track header of Track 1: Chuck Vox. The flex modes are
listed in the pop-up menu.

Slicing

Rhythmic
Manophonic
Polyphonic

Tempophone

" Trumper1
3 Speed

= Click the Flex Mode parameter in the Inspector’s Track Parameter box. The flex modes
are listed in the pop-up menu.

uo
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Creating and Moving Flex Markers in Flex View

You use flex markers to manually alter the timing of audio material. You can create
single or multiple flex markers in an audio file, enabling you to manipulate whole or
partial areas of the material by moving these flex markers.

Getting Ready
Define a cycle range for soloed playback and set an appropriate zoom level:
1 Click the Solo (S) button on Track 1: Chuck Vox to solo the entire track.

¥ Global Tracks

> Marker
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2 Click the gray shaded area in the upper part of the Bar ruler to turn on Cycle mode,
then change the left and right locators in the Transport barto 911 1and 1011 1,
respectively.

Left locator, | Right locator

SELLotaiuis ilepeai aecion ciob bl oy ciapoaead

+ Track v Region v MIDI v |Addic v View +|

3 Holding down the Option and Control keys (which activates the Zoom tool), drag
across the first region “Chuck Vox.1” on Track 1: Chuck Vox, dragging between bars 9
and 10 only.
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Try This

Create and drag a single flex marker:

Click the Flex Mode menu in the track header of Track 1: Chuck Vox, then choose
Monophonic from the pop-up menu.

—_

All audio files on the track are analyzed for transients, and all detected transients are
marked and stored in the audio files.

Transient marker

2 Press the Space bar to start playback.
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3 Place the pointer over the upper half of the audio region just before bar 9.3, just on top
of the existing transient marker. The pointer shown here indicates an existing transient

marker:

T B e e Snap: [Smart 11| Drag: [ o Overien il

4 Click the area on top of the transient marker to create a flex ma
Featkiv ] Ragionsn NIy At s | VWA, Sonz (St (o Dcilen

'[8

Chuck Vox10 Chuck Vox.1 L Chuck Vox.1

rker.

Flex marker
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5 Drag the flex marker to the right, as far as bar 9 3 3 1. It should look as follows:

BT ——

R R B P Snaps [Smart %] Drag: [ Vo Ovarizn Bl

Chuck Vox1

Time expanded audio| |Time compressed audio

The audio material to the left of the flex marker is time expanded (indicated by the

orange color) and the audio material to the right is time compressed (indicated by
green).

6 Listen to the result of this time stretching and compression.
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Create and drag multiple flex markers:

1 Place the pointer over the lower half of the audio region after bar 9 2 3 1, just on
top of the existing transient marker. The pointer shown here indicates an existing
transient marker:

ack v Region v MIDI v Audio v View v Snap: [Smart 1] Drag: [ Ko Overiap gNNER

3¢

‘Chuck Vox.1
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2 Click the transient marker.

Three flex markers are created—on the clicked transient marker, on the previous
transient marker, and on the next transient marker:

ack v Region v MIDI v Audio v View v|
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3 Experiment with time compression and expansion by dragging the middle flex marker
to the right or to the left.
Depending on the direction you move the middle flex marker, the audio material
between the center and right flex markers is either time compressed or expanded, and
the same is true for the audio material between the center and left flex markers.

ack v Region v MIDI v Audio v View ) snap: [Smart 1] Orag: [NoOverian  :] [k +]

9.4

Time expanded audiltjl_lLlJTime compressed audio

4 Press the Space bar to listen to the result of this time stretching and compression.
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Creating and Moving Flex Markers with the Flex Tool

You also have access to Flex Time editing with the Flex tool. The Flex tool allows you to
drag points in the region’s waveform and move them where you want. The waveform’s
movement is restricted by transient markers on either side of the place you began
dragging. To extend the editing area, drag beyond these transients and the boundary
will extend to the next or previous transient.

Getting Ready

Turn off Flex view and select the Flex tool:

Choose View > Flex View. Flex view is turned off and all audio tracks return to their
default view. Select the Flex tool from the Tool menu in the Arrange area.

Chapter 7 Flex Time Editing
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Try This
Create and drag flex markers with the Flex tool:

1 Place the pointer over the audio region to the right of 9.3. You'll know that the pointer
is on top of an existing transient marker when it looks as follows:

T TI——N———.
T T v ] soap: [Smare 7] Drag: [Woovariee 1 [ .

Chuck Vox.1 Chuck Vox.1 Chuck Vox.1

G Liop s by clapiesd susice keyioaa boice _naisa st neaia

frack. v] Region v | MIDI_v| Audio_v| View v] Snap: [Smart %] Drag: [ No Overiap. 3l <)

Chuck Vox.1 Chuck Vox.1 Chuck Vox.1
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The audio material to the right of the dragged flex marker is time expanded up to the
following flex marker. The audio material to the left of the dragged flex marker is time
compressed up to the previous flex marker.

Press the Space bar to listen to the result of this time stretching and compression.

Quantizing Audio

If you're not happy with the timing of your performance, you can use the Quantize
feature to correct the timing of audio material to the nearest selected musical time
value. This feature is only available for audio tracks that have been enabled for Flex
Time editing.

To quantize audio, you use the Quantize pop-up menu in the Inspector’s Region
Parameter box.

@00
(1)
I] ¥ Chuck Vox.1 |
i Quantize: off (3340) & Click here to open the
O==wing; Quantize menu.
Loop: [
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Getting Ready
Make sure that Track 1: Chuck Vox is no longer soloed by turning off its Solo button.

Try This
Apply quantization to a region:
Select the Tambourine region on Track 32: Tambourine.

-y

2 Click the Set Locators button in the Arrange toolbar, then press the Space bar to start
playback.

Choose Monophonic from the track header’s Flex Mode pop-up menu.
During playback, choose 8C Swing from the Quantize pop-up menu.

Listen to the playback result.

[o) NV, B - N V)

Repeat steps 2 to 5 for other regions in the demo project.
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Key Concepts
Flex Time editing: A process that allows you to edit the timing of single or multiple
audio regions.

Flex mode: A track-based setting that detemines how the timing of your audio will
be altered.

Transient marker: A marker that denotes a significant point or peak in an audio file.

Transient detection process: A process that analyzes audio files for transients the first
time you enable a track for Flex Time editing. Detected transients are marked and
stored in the audio files.

Flex marker: A marker that you drag to alter the timing of audio material.

Flex tool: A tool that allows you quick access to the basic Flex Time editing
functionality, without having to turn on Flex view in the Arrange area.

Quantization: The process of correcting the timing of your material.

Quantize pop-up menu: A menu in the Region Parameter box that allows you to set
the value used for quantization.

Chapter 7 Flex Time Editing

Flex view: An Arrange area view that allows you to edit the timing of audio material.
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Editing MIDI Events 8

You use the MIDI editors to edit the position, length, pitch, and
velocity of MIDI events in MIDI regions.

You can edit individual MIDI events by selecting a MIDI region in the Arrange area and
opening one of the MIDI editors. Which editor you use depends on the type of editing
you want to carry out. In this chapter, you'll explore some of the editors while also
looking at the editing capabilities of the Piano Roll Editor in more depth.

Exploring the MIDI Editors

In the Piano Roll Editor, MIDI note events are represented by horizontal rectangles,
aligned on a grid of horizontal and vertical lines. In the Score Editor, they are
represented by traditional music notation.

Getting Ready
= Open “The Numbers Game” demo project.
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Try This
Select a MIDI region and open the Piano Roll Editor:

= Select the first MIDI region on Track 14: Bass, and click the Piano Roll button at the

bottom of the Arrange area (or press the P key).

The MIDI events are represented by horizontal rectangles.

Gre Fill

(@] 58 [ ] 8] [ et » Functions v View <] [om (38401

» Global .

« The horizontal placement of note events indicates their temporal (bar, beat, and sub-
beat) positioning within the region and project.

* The vertical placement of note events indicates their pitch—the higher the note
position in the Piano Roll area, the higher the pitch.

» The length of the rectangle is directly proportional to the note event length.
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* The color of the rectangle and the horizontal line through the beam indicate the
velocity of the note event—how loud the note is played.

Open the Score Editor:

Click the Score button at the bottom of the Arrange area (or press the N key). The note
events of the selected MIDI region are displayed as traditional notation in the Score
Editor.

13 Gir Fill

14 iy Bass

ntro Intro

J Mixer | Sample Editor | PianoRoll | Seore | HyperEditor |
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Selecting Notes
You'll use the Pointer tool to select note events in the Piano Roll Editor.

Getting Ready
= Open the Piano Roll Editor by pressing the P key.

Try This
Select note events:

= Click any note event in the Piano Roll area. The note event is selected and is played
back at the same time.

= Click the Piano Roll background, then drag across several note events.
Select note events of the same pitch:

= Click one of the Piano Roll keys at the left of the Piano Roll area. All notes of the same
pitch are selected while also being played back.

ixer[ | Sample Editor ‘M Score | Hyper Editor

Click a Piano Roll key to select
all notes of the same pitch.
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= Drag across a range of Piano Roll keys. All note events in the pitch range are selected.

Hyper Editor |

ST

Drag across the Piano Roll
keys to select all notes of
multiple pitches.
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Creating Notes
You'll use the Pencil tool to create note events in the Piano Roll Editor. The Pencil tool is
assigned to the Command-click tool in the Piano Roll Editor by default.

Try This

Create note events:

Holding down the Command key (which activates the Pencil tool), click your chosen
position and pitch in the Piano Roll Editor.

Click with the Pencil tool to
create a note event.

= Holding down the Command key, click an existing note event, then click your chosen
position and pitch in the Piano Roll Editor. A new note event is created with the same
channel, velocity, and length as the note event you clicked.
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Editing the Position of Notes

You can move selected note events by dragging them in the Piano Roll Editor. If you
move a note event horizontally, it is moved in time. If you move a note event vertically,
it is transposed—moved up or down in pitch.

Try This

Move note events:
= Drag any note event horizontally.

=y

3 2 4161

| Semple edivor | pianoRall |  Score | Hypercditor

= Drag across multiple note events to select them, then drag them to another position.

Copy note events:
= Holding down the Option key, drag any note event horizontally, only releasing the
Option key after releasing the mouse button. The note event is copied.

Copy Events
Note 1 G#1 80
3 3 1161

| Sample Editor | Pianokell [  Score | HyperEditor |
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Change the pitch of note events:
= Click any Piano Roll key to select all note events of the same pitch, then drag the note
events vertically.

Mixer Sample Editor Score

The pitch of the selected note events is changed.
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Editing the Length of Notes
You can edit the length of note events in the Piano Roll Editor individually or in relation
to one another.

Try This

Change the length of a note event:

Drag the left or right edge of any note event. The event is either shortened or
lengthened, depending on the direction you dragged.

Length Change
Note 1 BI 127

3 1 4217

Score | Hyper(

Select any two note events, then hold down the Shift key while dragging the right
edge of one of them.The same end point is set for both notes.

Chapter 8 Editing MIDI Events
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= Select any two note events, then hold down the Shift and Option keys while dragging
the right edge of one of them. The same length is set for both notes and you can resize

them.

==
Equal Length

Note 1 C2 127
3 34 5

| ixer | Sample Editor ‘M | Hyper Editor

= Select any note event, then choose Functions > Note Events > Note Force Legato
(selected/any) from the local menu bar. The selected note is lengthened up to the
following note event, regardless of whether the following note is selected or not.

= Select any two note events (click the first and Shift-click the second), then choose
Functions > Note Events > Note Force Legato (selected/selected). The selected note
event is lengthened up to the next selected note event.
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Muting Notes

You'll use the Mute tool to mute selected note events in the Piano Roll Editor.

Getting Ready
Select the Mute tool from the Tool menu in the Piano Roll Editor.

Mute tool

Try This

Mute note events:

Click any note event with the Mute tool. The note is dimmed and can no longer be
heard during playback.

Click with the Mute tool to
mute the note event.

Click the note event a second time with the Mute tool to unmute it.

Drag across multiple note events, then click one of them with the Mute tool. All notes
in the selection are dimmed and no longer heard during playback. Click one of the
note events a second time with the Mute tool to unmute them all.

Chapter 8 Editing MIDI Events
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= Click any Piano Roll key with the Mute tool. All note events of that particular pitch are
muted. Click the Piano Roll key a second time with the Mute tool to unmute them all.

Editing the Velocity of Notes

You'll use the Velocity tool to edit note velocity in the Piano Roll Editor.

Both the color of the rectangle and the horizontal line through the beam indicate the
velocity of the note event—the force at which the note is played.

Low velocity

— High velocity

| Sample Editor | Piano Rell |
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Getting Ready
Select the Velocity tool from the Tool menu in the Piano Roll Editor.

Velocity tool

Try This

Change the velocity of note events:

Drag any note event downward with the Velocity tool. A help tag indicates the velocity
value of the note you have clicked, with this value decreasing as you drag downward.
The note color changes and the horizontal line inside the beam shortens.

Drag the same note event upward, while watching the help tag, the note color, and the
horizontal line.
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Quantizing Notes

You use the Quantize pop-up menu in the Piano Roll Editor to assign a quantization
value to one or more selected note events. You can also use the Quantize button to
quantize selected events with the value chosen from the Quantize pop-up menu.

Quantize pop-up menu Quantize button

| .- ]

t v Functions v View v/ |1/192-Note s.hald

1 Ranions

Try This

Correct the timing of note events:

Select one or more note events in the Piano Roll Editor, then choose a quantization
value from the Quantize pop-up menu. The selected note events map to the grid
according to the chosen quantization value.

Select additional note events, then click the Quantize button. The selected note events
map to the grid according to the previously chosen quantization value.
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Key Concepts
» MIDI region: A container for MIDI events—individual MIDI notes or commands—that
are generally created with a MIDI keyboard.

MIDI event: Represents an individual MIDI note or command.

Piano Roll Editor: Where MIDI note events are represented by horizontal rectangles,
aligned on a grid of horizontal and vertical lines.

Score Editor: Where MIDI note events are displayed as traditional music notation.

Velocity: Defines the force at which a note is played.

Transposition: The process of moving a note event up or down in pitch.

Cycle function: A function that constantly repeats the area between the left and right
locator positions.

Left and right locators: Locators that define the start and end points of a cycle range
in the Bar ruler.

Quantization: The process of correcting the timing of your material.

Quantize pop-up menu: A menu in the Piano Roll Editor that you use to correct the
timing of MIDI notes to the nearest selected musical time value.

Quantize button: A button in the Piano Roll Editor that allows you to quantize
selected events using the value chosen in the Quantize pop-up menu.
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Mixing the Project

You use the Mixer when you want to refine the sound of each
musical element in your project—creating a unified mix.

In this chapter, you'll explore the Mixer, work with channel strip groups, work with send
effects, and create submixes. When working on each of these tasks in the Mixer, you'll
encounter the following channel strip types:

* Audio channel strips: Control the playback and recording of audio signals on audio tracks.

« Instrument channel strips: Allow you to use and control software instruments.
Software instrument plug-ins are inserted into the channel strip’s Instrument slot. The
instrument channel strip can then be driven by a recorded MIDI region or by direct
MIDI input—playing your MIDI keyboard.

» Aux channel strips: Used to set up send returns, where a channel strip signal is routed
to an aux channel strip for effects processing. Aux channel strips are also used for
grouping purposes and for distributing a signal to multiple destinations via sends.

 Output channel strips: Represent the physical audio outputs of your audio interface.
These channel strips are used to adjust the overall volume and stereo/pan balance of
all audio, instrument, or aux channel strips routed into them.

 Master channel strip: A global level control for all output channel strips. It changes the
gain of output channel strips without affecting the level relationships between them.
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Exploring the Mixer

The Mixer provides options for changing what channel strips are being viewed and in
what order. The default settings display all the channel strips in the order they appear
in the Arrange area, along with the aux and output channel strips they are sending
signals to.

|View buttons | Filter buttons

GuitarWa  GuitarRev  GerFil
it 2 1
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As projects grow large and more complex, you may find it useful to temporarily limit
the number of channel strips displayed to those you need to focus on for a given task.
You have the possibility to switch the Mixer between three different views—Single,
Arrange, and All. You can also determine which channel strips are displayed using the
filter buttons.

Getting Ready
Open the Mixer area in the demo project:
Open “The Numbers Game” demo project.

Click the Mixer button at the bottom of the Arrange area (or press the X key).

Try This

Customize the Mixer view using the filter buttons:

Deactivate all filter buttons except for the Inst button. Only instrument channel strips
are now visible in the Mixer area.

Activate the Audio button and deactivate the Inst button. Only audio channel strips are
now visible in the Mixer area.

Customize the Mixer using the view buttons:

Select the channel strip Chuck Vox 1, then click the Single button. Single view limits
the Mixer display to a single channel strip—that of the track selected in the Arrange
area—and its signal flow.

Click the Arrange button. In Arrange view, the Mixer displays all channel strips that
correspond to tracks used in the Arrange window and their signal flow. In this case,
your settings from when you last activated the Audio button, and deactivated all
others, are still intact. The settings are saved with the view.

Chapter 9 Mixing the Project 143



Working with Channel Strip Groups

You can create a channel strip group and modify selected parameters for the entire
group using a single control. You do this by selecting multiple channel strips and
assigning them to a particular group from the channel strip’s Group slot.

Group slot

Pan control

Volume fader

Try This
Create a group from multiple channel strips:

1 Drag horizontally across channel strips 2 to 9 (over the word Inserts, or 1/0 text, for
example) to select them.

2 Click the Group slot of any one of these eight channel strips, then choose Group 2 from
the pop-up menu.
The group number is assigned to the channel strip Group slots and the Group Settings
window opens automatically. The Group Settings window determines which controls
and parameters are synced for those channel strips that make up the group.
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3 Double-click the Name field, type “Horns,” then press the Return key.
The group name is added to the group number on the channel strip Group slots.

The selected channel strips
are all assigned to group 2:
Horns.
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Close the Group Settings window by clicking the window’s close button.

Add another channel strip to the last created group:
Option-click the Group slot of channel strip 10 (another horn channel strip). The
channel strip is added to the previously created group 2: Horns.

Change the settings of an active group:

Click the Group slot of channel strip 2, choose Open Group Settings from the pop-up
menu, select the Solo checkbox, then close the Group Settings window.

Back in the Mixer, click the Solo button on channel strip 2.

All nine channel strips in Group 2: Horns are soloed.

Modify the volume level for the group:
Drag the Volume fader of any channel strip in Group 2: Horns. The Volume fader moves
for each channel strip, while maintaining the relative values between them.

Modify the Pan control for the group:

Drag the Pan control of any channel strip in Group 2: Horns vertically or horizontally.
The Pan control moves for each channel strip, while maintaining the relative values
between them.
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Adding Effects to Multiple Channel Strips
Chapter 3 discussed using Insert slots to add effects into a channel strip’s signal flow.
But what if you want to use the same effect on more than one channel strip?

You do this using Send slots—sending the signal on each channel strip to the same
aux channel strip, on which you add the effects.

Insert slot

Send slot

Try This
Add an effect to multiple channel strips:
Drag horizontally across channel strips 14 and 15 to select them.

Click the top empty Send slot of either channel strip, then choose Bus 6 from the Bus
pop-up menu, for example.
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The Bus number is assigned to both Send slots, and Aux 6—an aux channel strip—is
automatically created (only in the case of an unused Bus assignment).

Send knob

3 Drag the Send knob on channel strip 14 or 15 to set the amount of signal that you want
to send to Aux 6.

As you do so, the send amount value is shown on the Send slot.
4 Double-click either Send slot to jump directly to Aux 6.
5 Click the top empty Insert slot of Aux 6, then choose an effect from the pop-up menu.

6 Modify the volume level and pan settings for the signal on Aux 6.
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Creating a Submix

Another useful mixing procedure is to “submix” multiple channel strips into one aux
channel strip. Like grouping, this makes it easy to control multiple channel strips. For
this to work, the complete signal from each channel strip needs to be routed to an aux
channel strip via the channel strip Output slots.

Output slot
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Try This

Create a submix:

Drag across channel strips 11 to 13 to select them all.

Click the Output slot on any of these channel strips, then choose Bus 7 from the Bus
pop-up menu, for example.

The Bus number is assigned to the Output slot of all three channel strips, and Aux 7 is
automatically created (only in the case of an unused Bus assignment).

3 Double-click any of the three Output slots to jump directly to Aux 7.

You now have a submix of the selected three channel strips. You can control this
submix by modifying the volume level and pan settings and loading additional effects
from Aux 7.

Routing Signals with a Multi-Output Instrument

Some software instruments allow you to isolate a sound and route it to its own
aux channel strip where it can be independently mixed and processed. Within
Logic Express, you can use Ultrabeat and the EXS 24 sampler for such purposes.

Getting Ready
Select channel strip 39 in the Mixer, then click the Single button. You are provided with
an immediate overview of channel strip 39 and its signal flow.
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Try This
Insert and set up a multi-output instrument:

1 Click the Instrument slot of channel strip 39 and make sure that Ultrabeat > Multi
Output is chosen.

2 Click the Add (+) button at the bottom of the channel strip.

Instrument slot with

Eli:tra beat loaded

Stereo Out  Master

Input slot set to UB 3-4

£
g
;

1

|

j

Add button

An aux channel strip is created with its Input slot set to UB 3-4.
3 Double-click the Instrument slot of channel strip 39.
The Ultrabeat plug-in window opens.
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4 Click the “out” column of the Snare entry in the plug-in window, then choose 3-4.

5 Double-click the EQ area on the aux channel strip to apply EQ.
6 Click the first Send slot of the aux channel strip, then choose Bus > Bus 2 (DrumVerb).
The snare signal is sent to the existing aux 2 channel strip (already set up for snare).

152 Chapter 9 Mixing the Project



Key Concepts

* Mixer: Interface area where you mix your project.

* Audio channel strips: Control the playback and recording of audio signals on audio
tracks.

* Instrument channel strips: Allow you to use and control software instruments.
Software instrument plug-ins are inserted into the channel strip’s Instrument slot.

» Aux channel strips: Used to set up send returns, where a channel strip signal is routed
to an aux channel strip for effects processing. Aux channel strips are also used for
grouping purposes and for distributing a signal to multiple destinations via sends.

« Output channel strips: Represent the physical audio outputs of your audio interface.

 Master channel strip: A global level control for all output channel strips.

* Mixer View buttons: Allow you to switch the Mixer between the Single, Arrange, and
All views, limiting the Mixer view to channel strips required for the task at hand.

« Mixer Filter buttons: Allow you to to filter the display of specific channel strip types.

« Group slot: Used to control a channel strip’s group assignment.

* Group Settings window: Where you define the behavior of each group.

* Volume fader: Used to set a channel strip’s playback or monitoring volume.

« Pan control: Used to control the position of the signal in the stereo image.

« Send slot: Used to route a channel strip’s signal to an aux channel strip.

 QOutput slot: Used to set the channel strip’s output path.

* Multi-Output Instrument: Allows you to isolate a sound and route it to its own aux
channel strip where it can be independently mixed and processed.
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Automating Your Mix

You can record, edit, and play back fully automated mixes in
Logic Express.

With the help of the Logic Express automation features, you can automate the controls
and parameters of channel strips and plug-ins by recording them and playing them
back. This allows you to create complex, animated mixes—with automatic channel strip
mutes, channel strip signals that pan from side to side, channel strip groups fading in
or out, and much more.

In this chapter, you'll explore how to automate the controls and parameters of channel
strips using track automation.
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Exploring Track Automation
Track automation is displayed on a transparent gray shaded area that runs the length
of your project.

Getting Ready
Open the demo project:
= Open “The Numbers Game” demo project.

Try This
Display track automation:

= With Track 1: Chuck Vox selected, choose View > Track Automation in the local menu
bar (or press the A key). The automation lane on Track 1: Chuck Vox is displayed, along
with some existing volume automation data.

= :|— Track automation lane

Volume automation data
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Set the automation mode for a track:
1 If you cannot see the Automation Mode menu in the track header of Track 1: Chuck
Vox, drag the lower-left corner of the track header downward.

Automation Mode menu

Trumpet 1

Drag here to zoom.

This zooms the track header area, allowing you to see the Automation Mode menu.

2 Click the Automation Mode menu on Track 1: Chuck Vox, then choose Read from the
pop-up menu.

e duio coon automaiion b de Locaiors itepeataection i cop apiit oy ciaxsac
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13

¥ Global Tracks

—— Automation Mode menu
set to Read mode

Choosing Read allows you to play back all automation that exists on the track.
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3 Click the Play button on the Transport bar (or press the Space bar) to start playback.

Play button

Watch how the Volume fader in the left Arrange channel strip changes during playback.
The volume fader follows the pre-recorded automation data on the track.

Switch between automation parameters:
Select Track 2: Trumpet 1.

-

The automation lane on Track 2: Trumpet 1 is displayed, along with some existing
volume automation data.

2 Click the Automation Parameter menu, then choose Pan from the pop-up menu.

= [@][£] [ W] [ it~ Trad v Region v MDI

¥ Global Tracks +

Automation Parameter
menu

Pan automation data is shown on Track 2: Trumpet 1.

158 Chapter 10 Automating Your Mix



-

Using Touch and Latch Modes

You can use Touch and Latch modes to create your own automation data.

Important: Don't use Write mode. All automation data on a track is erased the minute
you start playback with Write mode enabled.

Try This

Create automation data using Touch mode:

Select Track 1: Chuck Vox, click the Automation Mode menu, then choose Touch from
the pop-up menu.

2 Press the Space bar to start playback.

Drag the Volume fader on the left Arrange channel strip vertically.

Volume fader

Release the Volume fader after a couple of bars.

The Volume fader follows existing automation data on the track.
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5 Drag the Volume fader vertically when you encounter existing automation data from
bar 9 onward.

The existing automation data is overwritten.
6 Release the Volume fader after a couple of bars.
The Volume fader once again follows existing automation data on the track.

7 Click the Stop button on the Transport bar (or press the Space bar) to stop playback.

Stop button

Touch mode allows you to modify the value of the chosen automation parameter
when automation is active. After releasing the fader or knob, the parameter follows
existing automation data on the track.
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Create automation data using Latch mode:
Click the Automation Mode menu on Track 1: Chuck Vox, then choose Latch from the
pop-up menu.

2 Press the Space bar to start playback.

3 Drag the Volume fader on the left Arrange channel strip vertically.

~N

Release the Volume fader after a couple of bars.

The Volume fader does not follow existing automation data on the track as in Touch
mode. Instead, the Volume fader continues to remain in the position at which you
released the mouse button.

Drag the Volume fader vertically when you encounter existing automation data from
bar 9 onward.

The existing automation data is overwritten.
Release the Volume fader after a couple of bars.

The Volume fader once again remains in the position at which you released the mouse
button.

Press the Space bar to start playback.

Latch mode works like Touch mode, but the current value replaces any existing
automation data after you release the fader or knob.
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Creating and Editing Automation Nodes and Lines
In this section, you'll experiment with creating and editing automation nodes and lines.

Line Node

Verse 1

[Chuck Vox 10 Chuck Vox.2 0

Chorus 1

Try This

Create automation nodes:

Click on, or just outside, an automation line (not on a node). A new node is created.
Hold down the Command key (which activates the Command-click tool with the
Marquee tool currently assigned) while dragging across a region. Click the marquee
selection area with the Pointer tool. A node is created at both marquee borders.
Select any region, then choose Track > Track Automation > Create Nodes at Region
Borders. One node is created at each end of the region.

You can also choose Track > Track Automation > Create Two Nodes at Region Borders
to create two nodes at each end of the region.

Edit automation nodes and lines:
Drag any of the existing automation nodes or lines vertically or horizontally.
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Draw in automation:
= Draw automation lines and curves in the automation track with the Pencil tool.

Draw in automation data
with the Pencil tool.

Key Concepts
« Automation: The ability to record, edit, and play back the movements of all knobs,
controls, and buttons on channel strips and plug-ins.

* Track automation: Automation displayed on an automation track.

» Automation Mode menu: A track header menu on automation tracks that determines
whether you read, touch, latch, or write automation data.

» Automation Parameter menu: A track header menu on automation tracks that allows
you to choose the visible automation parameter on the track automation lane.

* Read mode: Automates the current track, using the existing automation data.

« Touch mode: Allows you to modify the value of the chosen automation parameter,
when automation is active. After releasing the fader or knob, the parameter follows
existing automation data on the track.

« Latch mode: Works like Touch mode, but the current value replaces any existing
automation data after you release the fader or knob.
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Getting Answers

There are additional resources you can use to get answers to
your questions about using Logic Express.

Now that you have learned about the basic features of Logic Express, you probably
have more questions. You can use Logic Express Help to find the answers you need.

Exploring Logic Express Help

Logic Express Help provides in-depth descriptions and instructions about the features
and controls (the tasks you can perform) with Logic Express.

Try This

Open the Logic Express User Manual:

In Logic Express, choose Help > Logic Express Help, then click Logic Express 9:
User Manual.

Open the Logic Express Instruments manual:
In Logic Express, choose Help > Logic Express Help, then click Logic Express 9:
Instruments.

Open the Logic Express Effects manual:
= |n Logic Express, choose Help > Logic Express Help, then click Logic Express 9: Effects.

165



Search for a specific topic that interests you:
Enter the topic of your choice in the search field at the top of the Help Viewer window.
Select topics from the search results list that you want to know more about.

When you search in the Logic Express manual, the search results include relevant topics
from the Logic Express Instruments and Logic Express Effects manuals as well.

Search for Apple Support information:
Choose Help > Logic Express Help, then click Logic Express Support. Browse topics that
interest you.

Read discussions on the Logic Express forum:
Choose Help > Logic Express Help, then click Logic Express Discussions in the list of
additional resources. Browse discussion topics that interest you.

What's Next?

You've now had a brief introduction to Logic Express and a selection of its features.
You can continue to experiment with the demo project files on your own or delete
them and start work with your own clips. Refer to Logic Express Help for the in-depth
information you need.
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